Calendar dates are displayed as MM/DD despite locale being DD/MM

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 20.0.6
Operating system and version (eg, Ubuntu 20.04): official docker image with :20 label
Apache or nginx version (eg, Apache 2.4.25): N/A
PHP version (eg, 7.4): N/A

The issue you are facing:

I enabled the Calendar app and the dates are given the eUS away (MM/DD/YYYY) despite my locale being French (so DD/MM/YYYY)

Is this the first time you’ve seen this error? (Y/N): Y (but I have not used the Calendar app so far)

Steps to replicate it:

  1. Set Language to English
  2. Set Locale to French
  3. Check how the date is displayed in Calendar

My user settings:

image

How Calendar is displayed:

image

1 Like

Hi, Did you ever find a solution for this? I have the same issue for an Australian based server.

Unfortunately not (and I moved to Seafile for now)

Yeah wrong date formats in the calendar are certainly not an issue in Seafile, because Seafile doesn’t offer a calendar :wink:

btw. your issue seems to be resolved in the meantime. When I set my server to English (US) / French (France) the calendar date of today is displayed as Mon 17/10/2022

@balter What are the exact Language and Locale settings on your server and what exactly is displayed incorrectly?

Thanks for the speedy reply @bb77. I’ve attached a couple of screen shots of the settings.

The second image show the date format as MM/DD/YYYY when the locale shows as DD/MM/YYYY

image

I’m also curious about the time format. The calendar currently shows AM/PM however I’d like 24h time.

I played around a bit with the Language and Locale settings, and I can reproduce your issue on my instance.

Furthermore, the Language setting also seems to have an effect on how the calendar displays the date, at least in combination with certain Locale settings. This shouldn’t be the case imho or maybe i don’t understand the logic behind it. Either way, there is definitely room for improvement. Maybe you can open an issue on Github, if there isn’t already one about this specific issue.

Your best bet for now is probably to set the Language to “English (British English)” and leave the Locale on “English (Australia)”. That way you will get at least the DD/MM/YYYY format in the calendar, but the time format would still be AM/PM unfortunately.

Yes, that was rather to say that I care less about this issue for now :slight_smile: