CalDAV working with DAVdroid but not Thunderbird

Hey,

I just upgraded to Nextcloud 10.0 and I thought it was a good idea to check out Nextclouds calendar and contacts functions since I never used them before (they look great so far by the way).

The only issue now is that Thunderbird won’t connect via CalDAV. I’m using Thunderbird v45.3.0 with Lightning 4.7.3. Nextcloud is hosted on nginx 1.10.0 with php-fpm (PHP 7) with the configuration taken from the official documentation. It’s also running on an own subdomain so there is no messy path redirection going on.

When connecting to /remote.php/dav/ or /remote.php/dav/principals/users/username/ Thunderbird prints the following error message:

Error code: DAV_DAV_NOT_CALDAV. Description: The resource at https://cloud.example.org/remote.php/dav/ is a DAV collection but not a CalDAV calendar

Which makes sense I guess since /remote.php/dav/ indeed doesn’t return a CalDAV collection but a DAV collection. I also confirmed this with

curl -u username -X PROPFIND https://cloud.example.org/remote.php/dav/

When manually adding a certain calendar like /remote.php/dav/calendars/username/default/ it works just fine but of course it would be nice to sync them all at once instead of adding them one by one.

Is this possible with Nextcloud 10 or do I have to add every calendar one by one?

Thanks for the help and have a good week.

This is a Thunderbird/Lightning limitation. You would have the same problem with any other DAV server. Unfortunately you have to add them one by one :frowning:

For reference, http://sabre.io/dav/clients/thunderbird/

Thanks. Is there a good Windows client that can sync them all at once or is Thunderbird still a good choice?

I would stick with Thunderbird. If you’re an Outlook fan, you can use the CalDav Synchronizer from https://sourceforge.net/projects/outlookcaldavsynchronizer/

I’m not sure about any other options.

Will stick with Thunderbird then. GUI is pretty good, so after the first time setup there shouldn’t be any other issues with it.

Thanks for the help.

i am using thunderbird with lighning witout any issue. I use the syntax:
–domain–/remote.php/caldav/calendars/–user–/defaultcalendar/

You need to declare the specific calender too, then it works.

I’m aware of that, it’s also in the OP. :slight_smile:
However, this question was about syncing all calendars at once.

I can’t even get a single calendar to work on Thunderbird 52.4.0 on Mac OS X. Does anybody have an idea?

In Thunderbird, I add the calendar by choosing “New Calendar” > “CalDav” and for the URL, i.e. https://–domain–/remote.php/dav/calendars/mathias/personal/ (the URL I can copy from the NC calendar app - so I am sure there is no typo in the URL I provided in Thunderbird).

First of all: when I add the calendar, I don’t get asked for username / password anywhere ?!
Also, I am not able to enable the calendar. When I select “Switch this calendar on” in the settings, it doesn’t stay turned on but gets unchecked right away.

Any ideas? Any help appreciated. Thanks.

what is the error console window in the TB Client showing?

Under the Network tab I get a 401 Unauthorized status back for the PROPFIND request.

Note: I use two-factor authentication, and I also already created a app password in my NC, but Thunderbird doesn’t asked me for any credentials anywhere.

Update: I also already cleared the saved password under Thunderbird > Settings > Security > Saved Password. Makes no difference.

On my other machine, Ubuntu using Evolution, I have no problems at all - everything works seemless with the very same calendar.

Where do you see where the specific calendar is named? From the NextCloud UI I can get the https://example.org/remote.php/dav/grouping/users/username/ link but not the ‘default’ or ‘personal’ or whatever the specific part should be.

Also I think it’s important to give a Thunderbird/Lightning specific link (and mention any other software that needs this link style). This is a pretty important integration for NextCloud calendars, and as Thunderbird gives a subtle soft error rather than a hard error, and you need to remove (unsubscribe from) the calendar and add it again to try to fix, it’s likely to stymie any user who doesn’t look at Thunderbird’s error console and search for the error that leads to this issue…

OK, as my NextCloud host explained - https://support.mayfirst.org/wiki/nextcloud - the link for a specific calendar is indeed what works with Thunderbird. I swear NextCloud wasn’t giving the last part of the link before when getting the calendar link when i tried it before. Maybe this is the first of many things the new Firefox fixes in my life…