Caldav/carddav und ocm-provider/ocs-provider Auflösungsprobleme

Hallo zusammen,
ich habe

  • Nextcloud 15.05 im Subfolder
  • /var/www/nextcloud/ (cloud.domain.de/nextcloud) auf einem
  • Ubuntu 16.04.01 Server mit
  • Apache 2 und
  • PHP 7.3.3.1
    und das Problem, dass ich bei den Sicherheits- und Einrichtungswarnungen die Meldungen bekomme, dass /ocm-provider/, /ocs-provider/, /.well-known/caldav und /.well-known/carddav nicht richtig aufgelöst werden kann.
  • Dein Webserver ist nicht ordnungsgemĂ€ĂŸ fĂŒr die Auflösung von “/ocm-provider/” eingerichtet. Dies hĂ€ngt höchstwahrscheinlich mit einer Webserverkonfiguration zusammen, die nicht aktualisiert wurde, um diesen Ordner direkt zu liefern. Bitte vergleiche Deine Konfiguration mit den mitgelieferten Rewrite-Regeln in “.htaccess” fĂŒr Apache oder den in der Nginx-Dokumentation bereitgestellten auf dessen Dokumentationsseite. Auf Nginx sind das typischerweise die Zeilen, die mit “location ~” beginnen und ein Update benötigen.

  • Dein Webserver ist nicht ordnungsgemĂ€ĂŸ fĂŒr die Auflösung von “/ocs-provider/” eingerichtet. Dies hĂ€ngt höchstwahrscheinlich mit einer Webserverkonfiguration zusammen, die nicht aktualisiert wurde, um diesen Ordner direkt zu liefern. Bitte vergleiche Deine Konfiguration mit den mitgelieferten Rewrite-Regeln in “.htaccess” fĂŒr Apache oder den in der Nginx-Dokumentation bereitgestellten auf dessen Dokumentationsseite. Auf Nginx sind das typischerweise die Zeilen, die mit “location ~” beginnen und ein Update benötigen.

  • Dein Web-Server ist nicht richtig eingerichtet um “/.well-known/caldav” aufzulösen. Weitere Informationen findest Du in der Dokumentation.

  • Dein Web-Server ist nicht richtig eingerichtet um “/.well-known/carddav” aufzulösen. Weitere Informationen findest Du in der Dokumentation.

Dazu gibt es jede Menge LösungsvorschlÀge im Netz. Die einen bearbeiten die .htaccess, die anderen die nextcloud.conf, wieder andere die default-ssl.conf.
Leider ist es offensichtlich bei jeder Ubuntu Version und bei div. Nextcloud Versionen anders und es kommt darauf an, ob Nextcloud im Document Root des Apaches oder in einem Subfolder installiert wird.
Ich blicke jedenfalls nicht mehr durch. Ich hab in allen möglichen Dateien und Stellen die entsprechenden Zeilen eingetragen und danach apache2 neu gestartet. Ich bekomme die Meldungen nicht weg.
Kann mir jemand ganz konkret sagen, an welcher Stelle ich was genau wo eintragen muss?
Hier mal meine Configs:
/etc/apache2/apache2.conf: https://pastebin.com/ftSEVkSd
/etc/apache2/sites-enabled/nextcloud.conf: https://pastebin.com/HHYyF6Ts
/var/www/nextcloud/.htaccess: https://pastebin.com/W28BQwVe
Falls noch eine fehlt, werde ich sie gerne noch nachreichen.

Achso, ich hab die Installation auch schon mehrmals upgegradet. Nextcloud 13 bis 15, Php5 -> Php7 etc.
Schon vorab vielen Dank fĂŒr jede Hilfe!!

Gruß

Michael

Hi,

ich habe das gleiche Problem. Die Redirect EintrÀge in der /etc/apache2/apache2.conf wirken sich nicht aus.

Redirect 301 /ocm-provider/ /nextcloud/ocm-provider/
Redirect 301 /ocs-provider/ /nextcloud/ocs-provider/
Redirect 301 /.well-known/carddav /nextcloud/remote.php/dav
Redirect 301 /.well-known/caldav /nextcloud/remote.php/dav

Ich habe eben auf 15.06 aktualisiert. Damit ist zumindest die /ocm-provider und /ocs-provider Meldung verschwunden