CalDav and CardDav iOS issues

I am trying to setup my iOS device with CalDav and CardDav.

Using this guide, I have been trying to setup CalDAV or CardDav however, I keep getting “Cannot connect using SSL”. I have SSL setup using a reverse proxy. The cert is not self-signed or anything like that.

Service discovery is working correctly. Heading to /.well-known/carddav or /.well-known/caldav redirects correctly.

I have tried:

  1. Altering port to 443 or 80.
  2. Using example.com/remote.php/dav/principals/users/USERNAME/ as the url.
  3. I have tried prefixing my instance url using https://.
  4. Checking the requests are not being blocked (all ok here).
  5. As I have MFA enabled, using an app password instead of password.

Any other suggestions?

Any help is much appriciated. Thanks.

1 Like

Solution found:
For my setup the SSL port is 443. Looks like iOS attemps to use 8443 by default.

  1. Generate an app password.
  2. For the server url supply: https://domain.name:443/remote.php/dav/principals/users/yourusername
  3. Enter your username in the username field.
  4. Enter the app password for the password if your account has MFA enabled.
    Profit.
3 Likes

I hit the same error and was able to quickly confirm that for me the problem was .well-known/caldav was not properly configured. So if a search for the error lead you here, definitely check all the steps that @anon72133131 rules out in their post.

Same problem. Solved with @anon72133131 answer on his own topic :slight_smile:

When updating the documentation, we figured out that the service discovery was not set up correctly requiring to set a more complicated link than actually needed. The documentation was updated to add a specific hint for the service discovery troubleshooting: Include link to service discovery trouble shooting in iOS sync guide by networkException · Pull Request #8318 · nextcloud/documentation · GitHub

1 Like