[CalDAV and Apple] Impossible to use CalDAV with Mac and iOS

Hello Nextcloud community!

I’ve been trying over and over to get my Nextcloud #apps:calendar synced with my macOS and iOS, but it keeps returning that it can’t verify the user or password of this account. It neither works on Thunderbird, neither with TLSync on Thundebird… It’s quite annoying, because I’ve just been pushing for a move from G Suite to Nextcloud at my non-profit to be more coherent, and it feels like we can’t get it work well without having a developer on board (we also have troubles setting up Collabora and OnlyOffice…).

I’ve read several forum threads (including “Nexcloud has stopped syncing with my calender using CalDAV” and “Nextcloud MacOS CalDAV woes”, and read several times the troubleshooting advice provided by Nextcloud, but as a non-developer, many things seem quite obscure to me.

At the moment, the only thing I seem to have managed to do, is to setup the .htaccess files on my FTP (it was my first time setting up FTP files…!), which seems to have worked because I don’t have any message in my Nextcloud Hub settings saying that the .caldav address is not configured.

My question is quite simple: is there any simple way to fix this issue (for a non-developer like me), or could anyone here me help with the configuration of these calendars? Or else, is there anyone I could pay to do this setup and get going? Is Nextcloud Gmbh providing configuration support on-demand for non-enterprise packages?

Many thanks in advance for your help!
P.S.: I’m sharing my configuration info in case it might help:

  • Nextcloud 19.0.2, setup with Cron (I don’t exactly know what this implies, but read that it is recommended)
  • MacOS 10.14.5
  • iOS 12.2.6
  • Web hosting at Infomaniak (which has a Nextcloud Hub plugin for auto-configuration)
  • Link from my Nextcloud calendar: mydomain_org/co/remote.php/dav/principals/users/me/
  • N.B.: I replaced the “.org” by “_org” and a removed the https:// here because as a newbie to this forum I can only share 4 links apparently.

Let me know if you need anything else! I’m also up for a live video conference with direct access to the FTP/Nextcloud settings to configure this properly if needed.

In Thunderbird, when I try to setup the account with TLSync, here is the error message I get:

mydomain_org/co/.well-known/caldav (PROPFIND)

<d:propfind xmlns:d=“DAV:”><d:prop><d:current-user-principal /></d:prop></d:propfind>


Object not found;!


Error 404


P.S. #2: In my Nextcloud settings, I also have one message telling me that there has been an error yesterday and something went wrong in the background jobs (but I have no clue how to fix this, and the troubleshooting procedure looks way beyond my IT capacities), along with 2 recommendation messages:

  • Aucun cache mĂ©moire n’est configurĂ©. Si possible, configurez un “memcache” pour amĂ©liorer les performances. Pour plus d’informations consultez la documentation.
  • Le module PHP OPcache n’est pas disponible.

As you seem quite experienced with the Hub and this Forum, maybe you might have a clue on this one too?

I’ve read several articles (see list here), but haven’t found anything to resolve the bug.

Are there any error messages in your nextcloud.log?

have you tried reaching your calender by the address that nextcloud, itself provides?

Hi @JimmyKater!

Thanks again for your support over here!

Oddly enough, I have retried the solution prescribed by @Bernie_O on Why doesn't calendar sync to iOS work?, and this time it has worked! (Apparently I’m not the only one to have tried a few times before getting it right. Maybe the server needs some time to update to the new .htaccess settings?)

Hopefully it will keep on working!

The solution is the following:

Check if service-discovery is working: visit with a browser https://cloud.myserver.com/.well-known/caldav
This should redirect you to the webdav interface and after entering user credentials you should see “This is the WebDAV interface. It can only be accessed by WebDAV clients such as the Nextcloud desktop sync client.”

If this is working, do that on the iOS device:
Settings -> “accounts+passwords” -> “add account” -> “other” -> “add caldav account”

As server enter only the domain name nothing else (in your example this would be “cloud.myserver.com ”). Also enter username and password for the nextcloud user and hit “proceed” in the upper right corner.

With working service-discovera iOS will automatically discover the proper url. Letsencrypt is no problem for iOS - it works here without any issues for the last year or so.


So I explicitly checked for this in the new 20.0.4 version with nginx proxy manager running.
It does redirect me in a browser, but without adding the redirection code for nginx it will not work with the iOS clients.

With Mac OS I spent LOT of time and the error was incredibly simple (and difficult to find).

I have minimum 10 char for the password, but my password is 9 char long. Everything is working perfectly (web site, nextcloud client, etc.). But calendar not. It doesn’t say anything except that from the mac control panel: username/password not working.

Changed password to 10 character et voilà everything working. It should be better logged as error, but I cannot find where the log is… except for apache log that are not useful.

1 Like