BUG: WebDAV external storage NOT working as it should

Hello,

I can not access WebDAV external storage without getting weird results in nextcloud.

I tried with
Nextcloud v.21.0.2 running on 1blu hosting , automatically installed via “easyapp” (which I assume is Installatron, a oneKlick installation and on ubuntu server).
and
same BUG with IONOS nextcloud v 20.0.8
Files are shown as folders… :roll_eyes:

Problem is that external storage with WebDAV does not mount correctly files and folders,

The connection is shown as “ok” with a green tick, but nothing works properly.
Neither gmx, nor pCloud, my Synology NAS - nothing!

All my WebDAV storage spaces works fine as Windown network drive but with Nextcloud I get only weird buggy results.

This is in web interface AND the client.
Files are displayed as directories and other weird bugs show up.

pCloud seems to be buggy anyway, but my Synology NAS and GMX Cloud and other WebDAV storage should at least work.

Maybe someone here has a solution for this?

Best ,
Steven

btw
I found same result with owncloud…