Blank files browser in nextcloud web interface

Nextcloud version (eg, 20.0.5): 23.0.0
Operating system and version (eg, Ubuntu 20.04): Debian 11
Apache or nginx version (eg, Apache 2.4.25): Nginx 1.20.2
PHP version (eg, 7.4): 8.0.15

The issue you are facing:

This morning I updated from Nextcloud 22, to Nextcloud 23. The upgrade was performed by changing the image tag in a docker-compose file and restarting the containers and didn’t encounter any issues or unexpected log messages.

After the update, I am now getting a mostly blank /apps/files/ that does not list any files or external storages (just has the header and left menu).

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Update NC from 22 to 23
  2. Open web interface and log in
  3. Go to Files
  4. See mostly blank page

There are no logs in the container output advising of any errors at the server side or errors in /data/nextcloud.log or /var/log/nginx/error.log, however there are javascript errors in console:

Screenshot from 2022-01-23 09-34-37

I can browse files fine using android clients, or via DAV. It is only the web interface that is having problems.

The issue persists across users and across different browsers.

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

<?php
$CONFIG = array (
  'datadirectory' => '/data',
  'apps_paths' => 
  array (
    0 => 
    array (
      'path' => '/nextcloud/apps',
      'url' => '/apps',
      'writable' => false,
    ),
    1 => 
    array (
      'path' => '/nextcloud/apps2',
      'url' => '/apps2',
      'writable' => true,
    ),
  ),
  'memcache.local' => '\\OC\\Memcache\\APCu',
  'instanceid' => 'redacted',
  'passwordsalt' => 'redacted',
  'secret' => 'redacted',
  'trusted_domains' => 
  array (
    0 => '192.168.0.168:8888',
    1 => 'redacted.fqdn',
  ),
  'trusted_proxies' =>
  array (
    0 => '192.168.0.168',
    1 => 'redacted.fqdn',
  ),
  'dbtype' => 'mysql',
  'version' => '23.0.0.10',
  'overwriteprotocol' => 'https',
  'dbname' => 'nextcloud',
  'dbhost' => 'mysql',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mail_from_address' => 'administrator',
  'logtimezone' => 'Pacific/Auckland',
  'logdateformat' => 'Y-m-d H:i:s',
  'mysql.utf8mb4' => true,
  'dbuser' => 'redacted',
  'dbpassword' => 'redacted',
  'installed' => true,
  'loglevel' => 0,
  'maintenance' => false,
  'theme' => '',
  'overwrite.cli.url' => 'https://redacted.url',
);

I have an nginx reverse proxy that is upstream of the nextcloud instance, that has the following configuration:

      more_set_headers "X-XSS-Protection: 1";
      more_set_headers "X-Content-Type-Options: nosniff";
      more_set_headers "X-Frame-Options: SAMEORIGIN";
      more_set_headers "Content-Security-Policy: frame-src 'self'; default-src 'self'; script-src 'self' 'unsafe-inline' blob: 'unsafe-eval' https://redacted.url https://maxcdn.bootstrapcdn.com https://ajax.googleapis.com; img-src 'self' data: https://secure.gravatar.com; style-src 'self' 'unsafe-inline' https://maxcdn.bootstrapcdn.com https://fonts.googleapis.com; font-src 'self' data: https://maxcdn.bootstrapcdn.com https://fonts.gstatic.com; form-action 'self'; upgrade-insecure-requests";
      more_set_headers "Referrer-Policy: strict-origin-when-cross-origin";
      more_set_headers "Permissions-Policy: geolocation=(none);midi=(self);notifications=(self);push=(self);sync-xhr=();microphone=(none);camera=(none);magnetometer=(none);gyroscope=(none);speaker=(self);vibrate=(self);fullscreen=(self);payment=(none);";
      more_clear_headers "X-Powered-By";

Update - This issue has magically resolved itself overnight.

I have the same problem, unfortunately waiting didn’t help me.