Big File Sync with Apache and Nginx ProxyPass

Hello Everyone, I am attempting to use the nginx file syncing feature and am seeing the following error in the client gui.

Server replied “413 Request Entity Too Large” to “PUT https://fakenextcloudserver.example/remote.php/dav/uploads/…”

I found the big_file_upload_configuration documentation, as well as other posts on these support forums, but I believe that I have either failed at configuring it correctly or my networking situation bares a little more effort.

I have a Nextcloud server that I installed with the install script. However I have a server that is fronting it via proxy_pass.

Here is the relevant parts of my Nginx configuration:

location / {
    proxy_intercept_errors on;
    proxy_set_header Host fakenextcloudserver.example;
    proxy_request_buffering off;
    client_max_body_size 10G;
    client_body_buffer_size 400M;

On the Nextcloud server I’ve included what I believe are the relevant configuration items:

post_max_size = 10G
upload_max_filesize = 10G
upload_tmp_dir = /mnt/nextcloudtmp

I’ve confirmed that the output of php -i mirrors that config.

/etc/apache2/sites-enabled/nextcloud_http_domain_self_signed.conf & nextcloud_tls_domain_self_signed.conf
<Directory "/var/www/nextcloud">
  LimitRequestBody  10737418240
  SSLRenegBufferSize  419430400

I’ve made sure to restart all the services that I made modifications to with systemctl restart SERVICE as well as looked in the apache and nginx logs for any 413 error codes, though none exist.

I have also attempted to run the max_chunk_size documented here on the server running Nextcloud but it does not appear to function.

Let me know if there is any other details that make sussing this out easier. Much Love.

Nextcloud version: 20.0.1
Operating system and version: Ubuntu 20.04
Apache version: Apache 2.4.41
Nginx version: 1.18.0
PHP version: 7.4