Benachrichtigungen aus Deck APP

Hallo zusammen,

ich habe eine Frage zur DECK App und der Benachrichtigung.

Was ich habe:
User angelegt inkl. gültiger E-Mail Adresse
DECK APP installiert
Board angelegt
Liste angelegt
Karte angelegt mit USER und Fälligkeit

Unter Einstellungen Aktivität die Haken gesetzt bei:
Änderungen in Deck APP = E-Mail
Beschreibung geändert = E-Mail
Kommentar = E-Mail

Unter Grundeinstellungen den E-Mail Server eingerichtet und Positiv getestet

Mein Problem:
Ich bekomme keine E-Mail

Was habe ich getestet:
Nicht im SPAM
Nutzungsberichte erhalte ich auch keine (vielleicht also eher globales Problem ans nur Problem von DECK)

Kann mir da jemand einen Tipp geben ???

Vielen Dank für die Mühe

Gruß

Bob

  • Bei welchen Anbieter? Was für ein Server? v-server, shared, root, usw. Oder Lokal?
    Provider

  • Auf welcher Hardware? PC, Raspberry PI, Banana, NAS usw…
    Provider

  • Betriebssystem sowie Version ALLER beteiligten Systeme
    Linux 3.10.0-962.3.2.lve1.5.35.el7.x86_64 x86_64

  • Nextcloud Version?
    21.0.0

  • PHP Version?
    7.4.16

  • Welche Datenbank? MySql,Engine X (Nginx),MariaDB usw…
    mysql

  • Apache version, usw.
    Keine Ahnung

  • Läuft NC in Docker,Snap oder VM
    Keine Ahnung

  • Netzwerk Aufgliederung: zb. Router>Switch>PI>
    Internet

  • Wurden vor kurzen Server Updates gemacht? Wenn ja von was?
    Keine Ahnung

  • Habt ihr die Logs angesehen von Nextcloud und von System?
    Nextcloud ja, verstehe nur Bahnhof

  • Bei was für einer Aktion ist der Fehler aufgetreten?

Hi, hast du evtl. Fehlermeldungen im Nextcloud log?

1 Like

Da sind einige drin, check ich aber nicht.
(Installation ist frisch, kann sein das diese vom Einrichten sind)

Grad nochmal einen Bericht angestoßen und was in DECK geändert
Das hat aber keinen neuen Eintrag ins Protokoll erzeugt.

Wärs möglich dass es einen Fehler gibt der ungefähr so lautet? TypeError: htmlspecialchars() expects parameter 1 to be string, int given · Issue #2727 · nextcloud/deck · GitHub

1 Like

Sowas habe ich gefunden:

(Davon ist das Logfile voll…)

context Error: Call to a member function getContainer() on null

  1. /********************private/AppFramework/Bootstrap/Coordinator.php - line 143:OC\AppFramework\Bootstrap\RegistrationContext->delegateContainerRegistrations({ deck: OCA\ … }})
  2. ********************lib/private/AppFramework/Bootstrap/Coordinator.php - line 86:OC\AppFramework\Bootstrap\Coordinator->registerApps([ “deck”])
  3. ********************de/lib/private/Installer.php - line 146:OC\AppFramework\Bootstrap\Coordinator->runLazyRegistration(“deck”)
  4. ********************apps/settings/lib/Controller/AppSettingsController.php - line 448:OC\Installer->installApp(“deck”)
  5. ********************/private/AppFramework/Http/Dispatcher.php - line 218:OCA\Settings\Controller\AppSettingsController->enableApps([ “deck”], [])

context Error: Call to a member function getContainer() on null

  1. ********************/lib/private/AppFramework/Bootstrap/Coordinator.php - line 143:OC\AppFramework\Bootstrap\RegistrationContext->delegateContainerRegistrations([])
  2. ********************/lib/private/AppFramework/Bootstrap/Coordinator.php - line 86:OC\AppFramework\Bootstrap\Coordinator->registerApps([ “tasks”])
  3. ********************/lib/private/Installer.php - line 146:OC\AppFramework\Bootstrap\Coordinator->runLazyRegistration(“tasks”)
  4. ********************apps/settings/lib/Controller/AppSettingsController.php - line 448:OC\Installer->installApp(“tasks”)
  5. ********************private/AppFramework/Http/Dispatcher.php - line 218:OCA\Settings\Controller\AppSettingsController->enableApps([ “tasks”], [])
  6. ********************lib/private/AppFramework/Http/Dispatcher.php - line 127:OC\AppFramework\Http\Dispatcher->executeController(OCA\Settings … {}, “enableApps”)
  7. / ********************/private/AppFramework/App.php - line 157:OC\AppFramework\Http\Dispatcher->dispatch(OCA\Settings … {}, “enableApps”)
  8. ********************lib/private/Route/Router.php - line 302:OC\AppFramework\App::main(“OCA\Settin … r”, “enableApps”, OC\AppFramew … {}, { _route: "s … "})
  9. ********************e/lib/base.php - line 993:OC\Route\Router->match("/settings/apps/enable")
  10. ********************/index.php - line 37:OC::handleRequest()

Hm… das war ein Fehler von NC21.0.0 und wird mit NC21.0.1 behoben sein: Nextcloud 21 beta 1 Error: Call to a member function getContainer() on null · Issue #24711 · nextcloud/server · GitHub
Allerdings weiß ich nicht ob das deinen Fehler verursacht. Hast du evtl. noch andere Fehlermeldungen in den Logs?

Ok, also ich habe 21.0.0 gehe ich auf Beta und stoße das update an,hänge ich hier:

Check for expected files

The following extra files have been found:

  • cgi-bin
  • cp_errordocument.shtml
  • 400.shtml
  • 401.shtml
  • 403.shtml
  • 404.shtml
  • 413.shtml
  • 500.shtml
  • error_log

sonst halt sowas immer drin mit unterschiedlichen Dateien

PHP Error: Undefined index: workflowengine at /***********************/lib/private/AppFramework/Bootstrap/RegistrationContext.php#404

  1. /***********************/lib/private/AppFramework/Bootstrap/RegistrationContext.php - line 404:OC\Log\ErrorHandler::onError(8, “Undefined i … e”, “/***********************r … p”, 404, { apps: [],r … "})
  2. ***********************lib/private/AppFramework/Bootstrap/Coordinator.php - line 143:OC\AppFramework\Bootstrap\RegistrationContext->delegateContainerRegistrations([])
    2.***********************lib/private/AppFramework/Bootstrap/Coordinator.php - line 86:OC\AppFramework\Bootstrap\Coordinator->registerApps([ “tasks”])
  3. ***********************/lib/private/Installer.php - line 146:OC\AppFramework\Bootstrap\Coordinator->runLazyRegistration(“tasks”)
  4. /apps/settings/lib/Controller/AppSettingsController.php - line 448:OC\Installer->installApp(“tasks”)
    5.
    /lib/private/AppFramework/Http/Dispatcher.php - line 218:OCA\Settings\Controller\AppSettingsController->enableApps([ “tasks”], [])
  5. ***********************/lib/private/AppFramework/Http/Dispatcher.php - line 127:OC\AppFramework\Http\Dispatcher->executeController(OCA\Settings … {}, “enableApps”)
  6. ***********************/lib/private/AppFramework/App.php - line 157:OC\AppFramework\Http\Dispatcher->dispatch(OCA\Settings … {}, “enableApps”)
  7. ***********************/lib/private/Route/Router.php - line 302:OC\AppFramework\App::main(“OCA\Settin … r”, “enableApps”, OC\AppFramew … {}, { _route: "s … "})
  8. ***********************/lib/base.php - line 993:OC\Route\Router->match("/settings/apps/enable")
  9. ***********************e/index.php - line 37:OC::handleRequest()

Jap, ist ebenfalls Nextcloud 21 beta 1 Error: Call to a member function getContainer() on null · Issue #24711 · nextcloud/server · GitHub

1 Like

dann sollte ich versuchen das 21.0.1 update zu bekommen und dann mal weiter schauen

Ja, möglicherweise kann man dann diesen Fehler bei der Fehlersuche ausschließen. Allerdings ist NC21.0.1 wohl aktuell noch nicht draußen… (erst RC1)
Außerdem: Failed to update indices with occ command after upgrade to NC 21.0.1 RC1 · Issue #26423 · nextcloud/server · GitHub

1 Like

Danke soweit für deinen Support

1 Like

Manchmal sind die Lösungen einfacher als man denkt…
…ich habe die Einstellungen zur Benachrichtigung global veraltet und nicht bei bereits aktiven Usern.
Nachdem ich es im User angepasst habe = geht :slight_smile:

Bei den Error Logs warte ich auf ein stabiles Update.

Nachtrag:

nach Update auf 21.0.1 sind die oben beschrieben Error Logs nichtmehr aufgetaucht.

Danke für den Support

1 Like