Baffled by using a purchased SSL Certificate

I’m running the 40 GB VM on ESXI. No issues until I go to install the certificate that is for our domain from GoDaddy. The instructions on the site all seem to be for LetsEncrypt, but when I tried to use it I was blocked from sending to Gmail due to being “self-signed”.

I was given a PFX from GoDaddy as well as a cert and bundle cert. I ran the instructions for extracting my key from the PFX via PEM… all very convoluted. But I had it running! I tested, all was well - integrated nicely with our Windows AD using LDAP. I figured we were gold. I went to sign in today and I couldn’t. I expect that an update killed it, so I reinstalled the VM from scratch, but can’t seem to get the certificate magic to kick in again, and can’t connect to the server with the /nextcloud. I can get onto Webmin using both IP and name.

Can someone please help me to figure out how to get this to use my paid certificate so that I can get the project back up again? Thanks!

The best way to go is usual, to provide more essential information for debugging, like
the used OS, the used web server, which message in detail is displayed in your web
browser when you try to access your Nextcloud instance, etc., etc.

Next I would check if a similar problem hasn’t already been reported by other users.

Windows 10 trying both IE 11 and Chrome 72.

Starting apache2 (via systemctl): apache2.serviceJob for apache2.service failed because the control process exited with error code. See “systemctl status apache2.service” and “journalctl -xe” for details.

When I run those two commands it says nothing useful. Just that start failed and that’s all.

Trying on IE shows me



If I turn off SSL I can get to the /nextcloud but see:

Access through untrusted domain

Please contact your administrator. If you are an administrator, edit the “trusted_domains” setting in config/config.php like the example in config.sample.php.

I scrapped that install and reinstalled the VM. I’ll get everything configured, do a backup, THEN try the certificate.

I ended up, like many, just installing a LetsEncrypt certificate. The process of getting certificates from GoDaddy, then having to rekey and redo all my servers was simply a pain. It was much easier just to whip up the LetsEncrypt one.

1 Like

I’m glad the VM works as intended with Let’s Encrypt. There is no reason to use a paid cert in my opinion, especially when it’s so easy to setup in the VM.

You could use your own cert though, but it requires some Linux skills involving Apache mostly.

I have a bought certificate for a couple of installations. It is not that hard to install if you get a crt file and a key file or get a pem file.

Sometimes you might need to link it with an intermediate cert as well.

If one doesn’t want to use a bought certificate. Let’s encrypt is a really good option. And if like in the VM being updated with certbot , dead simple to use.