Auto Upload Stops - iOS

Hello everyone,

Recently I installed NextCloud application on my phone and everything went smoothly. Images were uploading automatically and everything seemed to be okay.

However, just recently issues started arising. Images start uploading but only first 200 or so. When they stop there’s no error or anything informative. If it helps I’m uploading everything via “admin” account.

I have tried:

  • Re-queuing files
  • Using a different upload directory
  • Reinstalling app
  • “Killing” the app and start it again
  • Taking in a picture in order to add more files to the queue (to maybe restarting it)
  • Setting display to “auto-lock disable” in order that phone wouldn’t lock while nextcloud was uploading --> SO app was always focused

However with no success. Does anyone know if this is general nextcloud issue, limitation or anything else? I would provide any errors, however, there are none :frowning:

Here is the information I know (about the components):
App version: 3.0.1
iOS version: 13.5.1
Phone model: iPhone 11 Pro
Server version: 18.0.4

I’m at the moment lost and any and every help is very appreciated, as it will lead me into the right direction toward the resolution.

Thank you to everyone in advance. Best Matt B.

got the same problem here. As I looked into the log, I found it’s very likely caused by the Nextcloud default upload size limitation. Find the solution here -> Uploading big files > 512M
After higher the max upload size to 2G, it worked fine with my iOS APP.

I’m having the same problem. Your link was helpful, however it states that the settings must be set in the nextcloud/.user.ini file. I have searched my server and this file doesn’t exist for me. I’ve installed Nextcloud using snapd. Do you happen to know what needs to be done?

its a hidden file.
in your nextcloud install directory do the command “ls -a” to see the file

I have found a soluten. Had the same problem. Worked on it for 3 days straight.
if you cancell the auto-upload there are like 5 files left.
I found out that these files where broken mp4’s on my cameraroll. just go ahead and delete these 5 files and it will run again. worked for me.

Cheers and let me know if it fixed it!
/A

Thank you!

Thank you, but no, that doesn’t solve my problem.

The problem that I’m having is when I run Nextcloud for the first time on iOS there is an option in the settings to “Upload the whole camera roll”. When I select that option Nextcloud will start to upload the files but then it will stop uploading. I’ve tried this on my wife’s phone and my son’s phone. On my wife’s phone there are over 900 files that won’t upload. Most of the files are small .jpg photos, a few megabytes. For my son’s phone there are only a few files left like what you said, however they are JPGs as well and all are around 1MB in size.

I don’t know enough about linux to troubleshoot the problem. After browsing the internet, this was the only forum that I found where someone else was experiencing the same problem.

Oddly enough when I installed Nextcloud on my phone several months ago I didn’t have this issue at all. Could be an issue with iOS 14.2 for all I know.

Did you enable background uploading for Nextcloud APP? I found that it wouldn’t resume if a bulk uploading stopped at some point, you have to clear the cache and restart upload by switching “upload whole camera roll” off and on again.

I can’t remember if I did the first time. I haven’t had time to troubleshoot this and since then my wife got a new phone and for some reason things have changed a bit. Originally the upload would stop with 1,011 files that wouldn’t upload. When I cancelled that upload there were 5 files left just like @Space_c1own mentioned. It’s weird because the first time I canceled there were 0 files left. Anyway, I deleted those 5 files and restarted the upload of the entire camera roll. When the upload started it shows around 940 files (I can’t remember the exact number) which is odd since originally there were more than 1,000 files cued. So because the phone was new iOS prompted me to allow background uploading via GPS location which I accepted. I made sure to keep the app open and not let the phone shut off and eventually it finished the process.

I’m not sure if I’m missing any files since it went from 1,000+ to around 940 so I’ll have to check when I have time.

Thanks again @wilsli, @fireboy987 and @Space_c1own. Your help is appreciated.