Auto save in collabora

Hi.
I’ve installed Collabora via Docker, as suggested. Is it possible to configure it for auto save? I didn’t find options in the editor itself or in the Nextcloud app settings.

Thanks

Hi @maxxer

For me it does auto save out of the box. If you see a checkmark in the toolbar, it should have already saved your changes.

2022-02-11_17-18

I have both NC and collabora running as separate docker containers… I can confirm there is a “save” button available. in my test I didn’t always left editing mode with top-right [x] button and my changes where saved but I couldn’t say if this is always the case.

But what I see in my instance, there is auto-save, maybe every 60-90 sec or so

2022-02-11 22_00_38-test234.odt - Nextcloud — Mozilla Firefox

  • doc wasn’t changed after 21:54 - I spend this time writing the post
  • pretty fast after subsequent change “unsaved” icon changed to “saved” state

might be there is no instant auto-save but in normal situation the doc should by good-enough

On my instance it does saving almost instant. I dont’t even know how the Icon looks in the new Nextcloud Office interface, when it hasn’t saved yet. Respective I was not able to provoke that condition.

I’m using Nextcloud 23.0.1 (manual install, without docker), Nextcloud Office 5.0.2 app, COOLWSD Version: 21.11.1.4 (Docker).

Hi.
I do have this checkbox, but I tried typing for 60s and it didn’t save. It even allowed me to close the document without saving…

Hmm not sure what’s wrong then or what’s causing your issue, sorry…

EDIT:
But now I suspect that it does not display / change the diffrent states / icons for the Save button correctly in the Nextcloud Office app on Nextcloud 23. Nevertheless, on my instance, all the changes I made were saved. And I waited 10 seconds tops before closing the document.

maybe you need to pause typing for 60 sec - this is what I did, I didn’t touch the interface after making a change… I could imagine they want to save somewhat “stable” states only… continuous saving would be very ineffective especially with bigger documents… maybe you get better answers in Collabora forums…

just tested with 23.0.2…

  • the interface definitely changed to “Nextcloud look”
  • there is no more “unsaved” icon
  • I tried to force data loss by typing some of characters (two upper lines) and closing the doc with a press on the [ x ] on the page (didn’t close the browser tab)
  • unsaved input was there, no data loss (NC23.0.2_docker_from_19.02.2022+collabora21.11.1.4.1)

image

UPDATE: there IS unsaved indicator (looks like floppy disk; “checkmark” shows “saved state”):