Auto-Backup suddenly fails due to read / write permissions

NCP v 1.12.3

When I start the manual backup process in the NCP panel, I get the message that the backup drive is a read-only file system. With my pi user on the system, I have the correct write / read permissions.
The backups worked always well since setting up the system. The backup drive is 4 TB and new (Western Digital), so there should be enough space left.

Any hints what may be the problem?

[ nc-backup ]
check free space...
du: cannot read directory '/var/www/nextcloud/data/appdata_ock2eglr1ojd/css/icons': Input/output error
du: cannot read directory '/var/www/nextcloud/data/appdata_ock2eglr1ojd/css/icons': Input/output error
clean up old backup /media/Backup_4TB/ncp-backups/nextcloud-bkp_20190429_1556499619.tar
rm: cannot remove '/media/Backup_4TB/ncp-backups/nextcloud-bkp_20190429_1556499619.tar': Read-only file system
Abort...
Maintenance mode already disabled
Abort...
Maintenance mode already disabled
Maintenance mode already disabled

I have writing permission with pi, but somehow the nc user does not. How to fix this?

pi@raspberrypi:~ $ cd /var/www/nextcloud/data/appdata_ock2eglr1ojd/css/
pi@raspberrypi:/var/www/nextcloud/data/appdata_ock2eglr1ojd/css $ ls
activity  core   files_sharing     files_trashbin  icons          systemtags
comments  files  files_texteditor  firstrunwizard  notifications  theming
pi@raspberrypi:/var/www/nextcloud/data/appdata_ock2eglr1ojd/css $

Here the data in the folder on the backup media

 139.04GiB   139.04GiB           -  /media/Backup_4TB/ncp-backups/nextcloud-bkp_20190422_1555894811.tar
 187.96GiB   187.96GiB           -  /media/Backup_4TB/ncp-backups/nextcloud-bkp_20190429_1556499619.tar
 191.07GiB   191.07GiB           -  /media/Backup_4TB/ncp-backups/nextcloud-bkp_20190508_1557277202.tar
 191.52GiB   191.52GiB           -  /media/Backup_4TB/ncp-backups/nextcloud-bkp_20190515_1557882004.tar
 709.61GiB   709.61GiB       0.00B  /media/Backup_4TB/ncp-backups

your hard drive is probably failing

Thank you very much!

The snapshots are done withouth any error, only the backup is not working. The HDD are both quite new and seem to have no error when checked. Also WD delivers good quality HDD.

What about the error message " Read-only file system? Is there any chance to restore the writing permission for the user on the Backup HDD? How could this be done?

I wonder if any of you has found a solution. I have the exact same problem. I wonder if the nc-backup-auto stopped working after some update and has been left like that ever since.

I really hope to hear that someone installed Nextcloudpi yesterday and nc-backup-auto worked as intended. This would be comforting for it would mean some kind of user error.