"Authentication Required" prompt after upgrade to 11.0

I had been running 9.0.53 and decided to take the plunge and upgrade to 11.0. So I manually upgraded first to 10.0.2 and then manually upgraded again to 11.0.0. I logged into the server as me (user account is an administrator). Since several apps needed to be enabled, I went to enable them but I get a prompt that says “Authentication required. This action requires you to confirm your password” I enter the password that I used to log in and it does not work. I get the same prompt again. I verified that the password that I am typing matches exactly with the one I used to log it but it does not work with this prompt. I also verified that the user that I am logging in as is an admin for the entire site, which it is. So I am at a loss. I even reset the password for the user using the “occ user:resetpassword” command line just to make sure.

Since 9.0.53 did not prompt me to reenter my password when enabling apps, either something is different with 11.0 or something went haywire when I upgraded from 9.0.53 to 10.0.2 to 11.0.0. Since I don’t know the logic behind the code, I’m not sure what it is looking for when it prompts me for the password when I enable an app (it also prompts me for a password when I try to change a user password…and does not work there either.) Obviously, it is not looking at the same place as main login screen does for user credentials since I can log into the server but the same password does not work at the enabling prompt.


1 Like

In your personnal settings, did you create or put something in the “application password” ?

No. I never set an separate application password when I was using 9.0.53. I’m not sure that this is an application password issue since it also prompts me for my password when I try to change a user password. It seems like there is another level of authentication that my password will not get me access to. This was not an issue before I upgraded.

Thanks for the quick reply!

Anything in the log ?

Nothing in the log about password failure when I try to enable an app. One thing that I did notice is that Caldav syncing is getting a login failure. I verified that the Calvdav client is using the correct password that I use to log in. So there seems to be a pattern. Password works when I log in to the Nextcloud server. But the same password fails for app enabling, user password changes, and Caldav syncing. What is the difference with user login credentials from 9.0.53 and 11.0.0? Hmmmm…

What’s your Caldav client ? If it’s Davdroid, you can get a nice and very detailed debug log if there is a syncing failure.

I just refer to this topic: NC11 won't accept my admin password?

Several people face this problem. As far as I could find out on the related github issue, there is at least a problem found for ldap users. But you are logged in as non-ldap user, am I right? Are there at least also ldap users/the app up in your nextcloud instance? Could be good to know in case, that the problem does not only exist for ldap users @nickvergessen

About CalDAV: I guess you did not yet adjust the dav links according to the change in NC11? Use “.../dav/...” instead of “.../caldav/...” or “.../carddav/...” now or to be sure: copy the new links shown in calendar/contacts ui now.

I have a new installation of NextCloud 11 and it’s doing it to me. I am not using LDAP and I haven’t been able to figure out what password it wants. Every password I’ve tried so far doesn’t seem to work. the password for my account has a length of 24 and includes special characters. I’ve tried shortening it to 10 and removing the special characters, it still doesn’t work.

There is no error in the apache log, I’m only seeing one ‘POST’ in the access log when I click ‘Confirm’

I think it would be a good feature if it would work but so far nothing I’ve tried has allowed me to use it.

I’ve wiped out next cloud and started over. I’m still having the same problem. I do not have the problem with CentOS 7, however I do have the problem with CentOS 6.8. Both are using PHP, both are running off Apache. I have the same behavior with each browser I’ve tried. The one I’m doing most o the testing on is Chrome.

On the new install. I’ve downloaded next cloud 11, in the config I put in my admin user and password, I’m using a mariaDB database. I go into my settings and try to make a change:

The password prompt comes up
I type the correct password
I receive no error message but the password prompt returns and the change has not been made
If I type in the Incorrect password I receive a “Failed to Authenticate” error

I am able to change my password, putting in my current password and the new one. I cannot however make any admin changes.

As I’ve mentioned the only difference I’m able to find is the OS version. The failures only happen in CentOS 6.8

They fixed one thing about LDAP. For the other bug, I’m not sure if they already have a clue. So it’s better to report this directly to the developers via github-bug report. Use the template with configuration details that developers can try to reproduce this error. If you can provide an image or access to a setup with that problem, that can be very helpful in some cases.

this was the related LDAP issue: https://github.com/nextcloud/server/issues/2734
Either join the discussion or open a completely new report, link to the previous report with similar symptoms but without LDAP.

I was able to fix it by setting the right time zone using ntpdate.

1 Like