Assistance with onlyoffice integration with Nextcloud 11.0.3

Hello Team,

I’m using Nextcloud 11.0.3 on CentOS 7 (nethserver). Nextcloud is up and running smoothly.

I’ve installed onlyoffice document server on a separate CentOS 7 server. I followed this guide to get onlyoffice document server installed:


One thing I had to add to this documentation to get my onlyoffice working was to autostart the services:

systemctl enable redis
systemctl enable rabbitmq-server
systemctl enable supervisord
systemctl enable nginx

This allows my onlyoffice server to run properly upon reboot.

So now I can successfully see the ‘Document server is running’ message when I go to my onlyoffice IP:

But as you can see I have not added an ssl cert to my onlyoffice yet.

So in my Nextcloud I’ve enabled the onlyoffice App. I’ve entered in the IP address of my onlyoffice server and upon saving these settings in Nextcloud I get a good message saying ‘Settings have been successfully updated’.

I now go to my files section of nextcloud and I can add an onlyoffice document. But when nextcloud opens a new tab to edit that document I get the following error message:

ONLYOFFICE not reached. Please contact admin

I’m looking for assistance on what would cause this error message? Do I need to have an ssl cert on my onlyoffice server in order to have Nextcloud connect? My nextcloud log does not show any errors for onlyoffice.

Thank you in advance for any advice you can provide me.

Perhaps because you’re running a mix of http and https?


If HTTPS is activated for Nextcloud, then it needs to be activated for onlyoffice as well.
Just as a side note.

Hope this helps

1 Like

I’m not running the docker instance of onlyoffice,I’ve installed onlyoffice document server in Centos as per my link.

Thanks @Schmu, I am running my Nextcloud with ssl installed. I was wondering if this was the reason. I’m setting up the ssl cert on my onlyoffice install this evening so we’ll see how it goes after that.

Latest browsers will block any HTTP requests of the the original URL is using HTTPS. This is done out of security reasons.

For example if you are using Chrome, when you press F12 it will open the Developers section which gives more information of the webpage, and there is an output section at the bottom. Most likely you will see some output similar to this:

1 Like

Thanks very much @StephanW for this information. My nextcloud does use HTTPS and my onlyoffice (for now) does not have an ssl cert. I’m struggling to get my wildcard cert installed in nginx. Would a self signed cert on my onlyoffice document server work if I import in the cert on each of my workstations where we use our Nextcloud?


that should work. Else if that doesn’t work you could try a test certificate from LetsEncrypt maybe.

I’m getting a little further into setting this up finally! I have my SSL cert working now and I can see my only office “Document Server is Running Page” finally. I’ve connected my Nextcloud to my only office and it says it’s a successful connection. But when I open a document or edit a document from my Nextcloud, onlyoffice tries to open in a new tab and stops with the error:

“The document could not be saved. Please check connection settings or contact your administrator”

Where do I need to set the setting in Nextcloud (or is it onlyoffice) to allow me saving my document in Nextcloud? I’m not seeing anything in the admin panel for onlyoffice on Nextcloud that suggests where I can set the location for saving?

Hopefully this community has seen this error and can provide a solution.

Thank you.

@greavette i sitting in front of the same problem for the last hours now. Did you solve it? Tryed nearly erverything i could think of. Had a Docker Container with nginx Proxy running for onlyoffice server, switch to a nother docker host with direct mapping of 80, 443 and finaly installed it barematal on a ubuntu system. Always the same… Document is loading and then

Dont know what else to do…

Hi @yashagoro86

Saw your post today first. I remember that error message being benign on my first server. There was an issue in Onlyoffice which was solved in a newer version. Maybe docker is still a little bit behind?
You could check if you can save changes to the document anyway - despite the error message.
If you can really save changes, than you probably need to wait for an update to the docker image of Onlyoffice.

Setting up a new server currently with the intention to install Onlyoffice as a docker image now, could you post your nginx config that forwards your requests to OO? If you have a good guide somewhere, I’d appreciate it :slight_smile:
Do you have nginx running as only web server application on your server or do you use Apache2 in addition?

Hey guys! Running nextcloud server at home and a document server on a VPS, you need to add the onlyoffice document servers url to the trusted sites on the nextcloud config.php.

Then only this setting worked for me -->

sudo docker run --net onlyoffice -i -t -d -p 443:443 --restart=always
-v /app/onlyoffice/DocumentServer/data:/var/www/onlyoffice/Data onlyoffice/documentserver \

Then I followed the onlyoffice tutorial found here -->

to get self-signed certs. I’m still trying to figure out how to get lets encrypt to work with the docker image. Let me know if you get any progress!