Asset-pipeline.enabled leads to a blank calendar with error

When enabling the ‘asset-pipeline.enabled’ in config.php an error occured in the calendar app.

Due to an upstream bug, the calendar is currently not able to provide support for the asset pipeline feature.
Please contact your administrator and ask them to disable the “asset-pipeline.enabled” config option.

It has been already discussed and fixed here: JS breaks when asset pipeline is enabled #205

Unfortunately it is not solved in the new release 9.0.51.
Who knows a workaround or when will it be part of nextcloud?

Cheers, Carsten


Easy one, disable asset pipeline. With ES6 being released not even JS minifiers are able to handle it completely yet. I don’t suspect that any PHP minifier will soon be able to handle it (if ever).

The correct solution to this problem is that Nextcloud and apps ship with minified JS

thanks for your responses.

sorry, i didn’t get it completely. could you please provide more (highlevel) details?

i already disabled this festure but i would really appreciate using this festure

cheers carsten

What I’m trying to say is that the asset pipeline uses a JavaScript minifier written in php which supports only a very old JavaScript version.

I don’t expect it to get updated any time soon so anything that uses a bit newer version will not work properly.

In a nutshell: asset pipeline is old and broken and (very likely) nothing will fix that. Don’t use it.

Many thanks - i got it and will mark this as solved

@BernhardPosselt do you know if this is something that is being worked on on nc? I do use the asset pipeline (although not the calendar app)

@totalcaos it is deprecated and people discuss about removing it alltogether