Appstore missing

Nextcloud version (eg, 20.0.5): 22.2.0 me
Operating system and version (eg, Ubuntu 20.04): Linux 5.14.10-200.fc34.x86_64 x86_64
Apache or nginx version (eg, Apache 2.4.25): httpd-2.4.50-1.fc34.x86_64
PHP version (eg, 7.4): 7.4.24

The issue you are facing:

I can’t see the app store inside nextcloud apps

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Install Nextcloud on Fedora
  2. Follow all the steps during the install guide

The output of your Nextcloud log in Admin > Logging:

{"reqId":"YWYbrzYzuSgNbgMc7qg5igAAAIo","level":2,"time":"2021-10-12T23:35:11+00:00","remoteAddr":"REDACTED_IP","user":"admin","app":"appstoreFetcher","method":"GET","url":"/index.php/settings/apps","message":"Could not connect to appstore: cURL error 7:  (see for","userAgent":"Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/94.0.4606.71 Safari/537.36","version":"","id":"616620571195d"}

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'passwordsalt' => 'REMOVED',
  'secret' => 'REMOVED',
  'trusted_domains' => 
  array (
    0 => 'REMOVED',
    1 => 'REMOVED'
  'datadirectory' => '/var/www/html/nextcloud/data/',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'http://localhost',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'REMOVED',
  'dbpassword' => 'REMOVED,
  'installed' => true,
  'instanceid' => 'REMOVED',

The output of your Apache/nginx/system log in /var/log/____:

Have you tried clearing your browser cache and seeing it that makes the appstore accessible?

I’ve tried different browser also. Still a no show.

Did it stop working at a certain point in updating or something else? Also, check your nextcloud.log for errors. Should also be accessible under admin user.

Perhaps it is the Lets Encrypt problem
Certificate has expired for apps.nextcloud and - #2 by mritzmann

It is a brand new install on a newly provisioned server. Here is the output from the nextcloud.log →

So my certs are working fine, just tested.