Appstore categories won't load

Nextcloud: 20.0.12
Operating system and version: Ubuntu 16.04.1
Apache: 2.4.18
PHP: 7.3

Appstore won’t show categories on the left. Checking logs it says curl error 60, ssl.

I’ve upgraded ca-certificates, I’ve even downloaded the new crt file for nextcloud and replaced the old in the config dir.

When I run curl to the Appstore url from the command line it works, no errors. If I open php interactive and run file_get_contents to the Appstore url it works also.

But can’t get the Appstore to work.

Do you like to use the app store in cli or browser?

Browser, didn’t know I could run Appstore from OCC in the cli?

For browser usage there should be no need to manually update any cert.
Or did I miss any information? You talked about config dir.
Which browser are you using?

Don’t see why browser would matter, since I can go to the Appstore url from that browser no issue. Firefox latest edition. Tried chrome as well.

Logs are massive, let me see if I can copy paste the error, I’m on mobile.

Finally found the issue after digging through the log once more! :slight_smile: For all those looking, file /var/data/files_external/rootcerts.crt needed replaced with the one from git repo ca-bundle.crt.

This line from the logs I found was complaining about that file:

"message": {
		"Exception": "GuzzleHttp\\Exception\\RequestException",
		"Message": "cURL error 60: SSL certificate problem: certificate has expired (see",
		"Code": 0,
		"Trace": [{
			"file": "/var/www/3rdparty/guzzlehttp/guzzle/src/Handler/CurlFactory.php",
			"line": 155,
			"function": "createRejection",
			"class": "GuzzleHttp\\Handler\\CurlFactory",
			"type": "::",
			"args": [{
				"sink": {
					"__class__": "GuzzleHttp\\Psr7\\Stream"
				"headers": [],
				"response": null,
				"request": {
					"__class__": "GuzzleHttp\\Psr7\\Request"
				"options": {
					"verify": "/var/data/files_external/rootcerts.crt",
					"timeout": 60,
					"synchronous": true,
					"handler": {
						"__class__": "GuzzleHttp\\HandlerStack"

All good now, now it loads the appstore. Thanks!

1 Like