apps/theming/ajax/updateLogo 500 (Internal Server Error)

Hi, i have some Fails with Theming Nextcloud.
I also moved to a new Server today.
I already correct every rights in Backend.
I ran repair Tool without Problems.

Please See Screenshot for the Errors.
I just want to upload a Background Images.
It wont stop to show “waiting” and errors go into Console.
Even CPU goes high and nothing happens.

Any Suggestions?

PHP Version: 7.0.22
max execution: 3600
max upload: 16 GB
mysql Version: 5.7.18
Nextcloud 12.0.2

Ubuntu 5.4.0-6ubuntu1~16.04.4)

Do you just use the theming app with a different color and logo? Or did you modify other files manually?

Can you check your logfiles? Your browser console shows an internal server error (error 500), there is usually more information in you webserver-errorlog.

Many files are cached in your browser, if you move your setup, update apps/themes, it can be worth clearing your browser cache.

1 Like

thank you.
I found following Fails in Error Log (Please see Screenshot)
i also cleared fully Cache before.
Doesn’t work.

There should be more errors. The .ocdata error is normal and unrelated. Perhaps you need to enable logging of php.

Hi, i turned on Errors via php.ini, restarted apache2 several Times. Nothing as i already showed you.
And its not Working. Console shows errors. Apache2 Log not. Not more than i already mentioned.

What else can i do?

here some more Fails.
Theres really something not good :frowning:
Any help i would appreciate


any News on this ?
still not working with NC 12.0.2
Still want to change Background but get Errors:

	    index	OCP\Files\NotPermittedException: No create permission for path
/var/www/nextcloud/lib/private/Files/SimpleFS/SimpleFolder.php - line 83: OC\Files\Node\Folder->newFile('background')
/var/www/nextcloud/apps/theming/lib/Controller/ThemingController.php - line 229: OC\Files\SimpleFS\SimpleFolder->newFile('background')
[internal function] OCA\Theming\Controller\ThemingController->updateLogo()
/var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php - line 160: call_user_func_array(Array, Array)
/var/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php - line 90: OC\AppFramework\Http\Dispatcher->executeController(Object(OCA\Theming\Controller\ThemingController), 'updateLogo')
/var/www/nextcloud/lib/private/AppFramework/App.php - line 114: OC\AppFramework\Http\Dispatcher->dispatch(Object(OCA\Theming\Controller\ThemingController), 'updateLogo')
/var/www/nextcloud/lib/private/AppFramework/Routing/RouteActionHandler.php - line 47: OC\AppFramework\App main('OCA\\Theming\\Con...', 'updateLogo', Object(OC\AppFramework\DependencyInjection\DIContainer), Array)
[internal function] OC\AppFramework\Routing\RouteActionHandler->__invoke(Array)
/var/www/nextcloud/lib/private/Route/Router.php - line 299: call_user_func(Object(OC\AppFramework\Routing\RouteActionHandler), Array)
/var/www/nextcloud/lib/base.php - line 1004: OC\Route\Router->match('/apps/theming/a...')
/var/www/nextcloud/index.php - line 48: OC handleRequest()

Some permission on the filesystem are perhaps wrong (everything should be accessible by www-data).

Can you reproduce this problem on the test setup:


what command do i have to run, to set everything in right permission?
im sure that i have checked this a several time.

Maybe theres missing somthing, but i was sure.
I checked the specific Path in the Error and theres everything fine.

EDIT: i ran this bash script: nothing changed. Still get same Errors.

EDIT2: its not stopping with annyoing Errors.
I cant even download TAR anymore. it stops always at 25,7 MB

Does no one has an Idea?

Thank you for your help all :smiley: … Makes really fun.
I just upgraded to v12.0.3 and NO its not gone.
Same Errors, same behaviour

just telling, in case somebody someday will read this and yeah - nothing :slight_smile:

Do you just change you theme via admin page?
If you don’t apply a modification to the theme, do you see any errors?

ideas @juliushaertl

thank you for help!
I always just trying to change Background IMG via Backend, yes!
if i go to “settings/admin/theming” in Backend there are only some Yellow warnings "DevTools failed to parse SourceMap"
as soon as i hit “Upload Image” regardles of PNG JPG whatever, the Console gets huge RED Warnings as you can see in Screenshots above.

@danse Looks like a lot of stuff is wrong there since there are so many permission related error messages. Please make sure that the data directory (especially the appdata subdirectory) is writable for your webserver.

Can you post the output of ls -l /path/to/nextcloud/data/appdata_[instanceid]/theming/ ?

Hi @juliushaertl,
thank you.

here’s the Output:

# ls -l
insgesamt 8
drwxr-xr-x 2 www-data www-data 4096 Sep 19 17:36 35
drwxr-x--- 2 www-data www-data 4096 Jun 27 10:37 images

Hi, any suggestions?

@juliushaertl, sorry its still not better.
I double checked all permissions.
run repair several times.

Is there any way to delete and reinstall theming - if yes how? as i tried this manually (delete app and install app) nothing changed.
This is since moving to another Server…

have no idea what i can do …

Uhm, today i want to finally delete Cloud and now i saw disabling Encryption from whole Server - i can upload Image again for Theming!!!
But Files Preview not work so i will delete it anyways but something is not right with encryption and theming…

There are a few fixes in the future 12.0.4; the release is available for testing

or directly test with NC 13 beta 1.