Apps not working in Nextcloud 14

Nextcloud version: 14.0.3
Operating system and version: Ubuntu 18.04
Apache or nginx version: Apache 2.4.34
PHP version: 7.1.19

The only Nextcloud apps that show for me are (in order): Files, Activity, Gallery, Calendar

If I disable any of these apps, its icon will disappear. If I re-enable it, the app icon will be back. So far, so good.

NONE of the other apps (even “official” ones) such as “Log Reader” or “PDF Viewer” will ever appear, irrespective of whether they are enabled or not.

Is this the first time you’ve seen this error? The problem has happened from the very beginning. It has never worked.

Steps to replicate it: Try to enable an app and witness that it doesn’t appear.

The output of your Nextcloud log in Admin > Logging:

I don’t see this option. Presumably, because “Log Reader” is not working.

The output of your config.php file in /path/to/nextcloud:

$CONFIG = array (
  'instanceid' => 'xxx',
  'passwordsalt' => 'xxx',
  'secret' => 'xxx',
  'trusted_domains' =>
  array (
    0 => 'aaa',
    1 => 'bbb',
    2 => 'ccc',
  'datadirectory' => '/srv/nextcloud/data',
  'overwrite.cli.url' => 'http://localhost:8082/nextcloud',
  'dbtype' => 'mysql',
  'version' => '',
  'logtimezone' => 'UTC',
  'installed' => true,
  'maintenance' => false,
  'dbname' => 'nextcloud',
  'dbhost' => '',
  'dbuser' => 'xx',
  'dbpassword' => 'yy',
  'theme' => '',
  'loglevel' => 2,
  '' => 'stable',
  'mail_from_address' => 'abc',
  'mail_smtpmode' => 'smtp',
  'mail_domain' => 'some.domain',
  'mail_smtphost' => 'smtp.some.domain',
  'appstore.experimental.enabled' => true,

How do I debug this?


This option is not listed in NC 14 any more (not in docu and not in sample). Could you try to set it to false, or bettere delete it and try again if it works?

It doesn’t. I only added it, because it wasn’t working as one attempt to fix the problem.

Not all apps come with their own interface and their own symbol. Some just integrate in existing apps. The PDF viewer just opens when you click on a PDF; the gallery is a bit different, it opens when you click on a picture you can as well open the app and it shows you the folders with pictures available on your storage. If you are not happy or have better ideas for some of the apps, go to the repository of the app and share your ideas with the developer.

Okay, that makes sense.

Any thoughts on the Markdown editor? How does that get invoked? I tried to find out looking at the app’s page, but they only talk about using it, not how to launch it. Clearly, one is supposed to know that already. I think I am missing something simple and obvious.

Just create a new textfile and then change the extension to .md. Though it would be nice to have a menu point when creating new files:

Awesome. Thanks!