Apps hidden when activating memcache


Nextcloud version : 10.0.3
Operating system and version : CentOS Linux release 7.3.1611 (Core)
Nginx version : 1.11.8
PHP version : 7.0.14



Log Nextcloud:

Error PHP Allowed memory size of 536870912 bytes exhausted (tried to allocate 4294971392 bytes) at /usr/share/nginx/html/nextcloud/lib/public/AppFramework/Http/JSONResponse.php#69 2017-01-20T14:17:10-03:00
Debug core No update found at the ownCloud appstore for app 166055

Log Neginx:

2017/01/20 14:17:10 [error] 4292#4292: *41 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: 177.19.133.236, server: sitecloud.com, request: “GET /settings/apps/list?category=enabled&includeUpdateInfo=0 HTTP/1.1”, upstream: “fastcgi://127.0.0.1:9000”, host: “sitecloud.com
2017/01/20 14:17:10 [error] 4292#4292: *212 FastCGI sent in stderr: “PHP message: PHP Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 4294971392 bytes) in /usr/share/nginx/html/nextcloud/lib/public/AppFramework/Http/JSONResponse.php on line 69” while reading response header from upstream, client: 177.19.133.236, server: sitecloud.com, request: “GET /settings/apps/categories HTTP/1.1”, upstream: “fastcgi://127.0.0.1:9000”, host: “sitecloud.com
2017/01/20 14:17:10 [error] 4292#4292: *214 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: 177.19.133.236, server: sitecloud.com, request: “GET /settings/apps/list?category=enabled&includeUpdateInfo=1 HTTP/1.1”, upstream: “fastcgi://127.0.0.1:9000”, host: “sitecloud.com
2017/01/20 14:17:16 [error] 4292#4292: *214 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: 177.19.133.236, server: sitecloud.com, request: “GET /settings/apps/list?category=disabled&includeUpdateInfo=0 HTTP/1.1”, upstream: “fastcgi://127.0.0.1:9000”, host: “sitecloud.com
2017/01/20 14:17:16 [error] 4292#4292: *214 recv() failed (104: Connection reset by peer) while reading response header from upstream, client: 177.19.133.236, server: sitecloud.com, request: “GET /settings/apps/list?category=disabled&includeUpdateInfo=1 HTTP/1.1”, upstream: “fastcgi://127.0.0.1:9000”, host: “sitecloud.com
2017/01/20 14:17:22 [error] 4292#4292: *253 access forbidden by rule, client: 177.19.133.236, server: sitecloud.com, request: “GET /data/htaccesstest.txt?t=1484932635092 HTTP/1.1”, host: “sitecloud.com
2017/01/20 14:17:28 [error] 4292#4292: *168 access forbidden by rule, client: 177.19.133.236, server: sitecloud.com, request: “GET /data/htaccesstest.txt?t=1484932641179 HTTP/1.1”, host: “sitecloud.com

PHP wants to use more than 512 MB RAM but you don’t give more. Give more memory or reduce the number of apps/functions.

I made the change, but it continues the same way.

Problem still persists
Rasbian on Banana PI M3
Nextcloud Version: 11.0.2 (stable)
Apache Version: 2.4.25 (Raspbian)
PHP Version: v7.0.16-3

When adding APCu entry in config.php, Apps Categories are missing.
Should we report that in Github as an Issue ?

For this explicit error, you can find some ideas how to debug it further:
https://bugs.php.net/bug.php?id=65584