Apps are not availabe nextcloud 13 - Ubuntu 18.04 Snap

Hello, i’ve enabled several apps in nextcloud 13, mindmap, onlyoffice, ownpad, and texteditor. some are 3rd party and texteditor is offical. The problem is only the mindmap icon has showed up at top of frame, im unable to access any of the other apps from anywhere even the offical texteditor. Just wondering what trick is to get the rest of them to show up i haven’t had any luck.
System ubuntu 18.04 server, with nextcloud snap.
(update: found texteditor have create file or upload text file there is no icon for it.)

nextcloud is awesome, but I have to say the app store implementation is kind of broken imo.
Having an easy to use kickass app store would bring many users and then devs, as you know.
Managing apps should be easy as the google play store, one button to install, icon appears, one button to remove then icon disappears. nothing else, no configs, no permissions, just works. I believe that being able to edit or work with your files is way more important than any other feature. The app store is one of the main reasons i chose nextcloud only to find out you need to use workarounds and manually configure apps to get them working. sorry for rant, keep up the great work and thank you for nextcloud.

First check your files and folder permission.

Second: disable all apps.
Then you can go to …/…/nextcloud/apps and rm all files.
After re-enabling all apps, you will be able to automatically redownload them.

What folder permissions should i check?

On debian, usually nextcloud is installed in /var/www/html/ or /var/www/html/nextcloud

ownership should be set to www-data:www-data
so do chown -R www-data:www-data /var/www/html/

html should be 775
nextcloud if present also 775
all other folder set as 755

im on Ubuntu 18.04 using snaps my path looks like.
/var/snap/nextcloud I changed the owner of /var/snap/ nextcloud and it locked me out so i changed it back.

there isn’t a /var/www or /var/www/html path. I tried deleting and re-enabling apps which didn’t work. Now i lost mindmap too, it was the only app that worked no worries.

Sorry, can’t help you.

I don’t like thise “already cooks” apps like snap because they differs from the usual built …

np, thanks for trying. snaps and flatpaks are the “future of application distribution”, it does simplify installtions but the usual paths are different. snap management is easy, fun tutorial here
thanks again

Sorry, i am not attacking, just my opinion.

They are not the future of application distribution. They are the lazy way for non-specific out of-the-box-like-microsoft apps for Linux biginners.

Most of the time you don’t even know the compiling options used. When experiencing troubles, you don,'t know if it the snappy faulty, a missing OS dependency, a config error …

The “by the sources compiling hardway” is hellish, the apt-get way is still complicated but at least you still have control.

Found the answer to my question onlyoffice require a second server aka “document server” to handle the documents. onlyoffice cant’ use nextcloud as a document server, it would be very cool if it could because then it could be baked into the snap )

The other apps work great, ones that don’t need additional servers, configuration, etc…