AppPathNotFoundException: Could not find path for spreed

I reported this on github but did not get any response, on a new and fresh NC installation, I have been getting this error randomly since start. I do not use or have spreed enabled (unless it comes by default)

Steps to reproduce

  1. Not exactly sure why or how it appears, I just see/find this error in my nextcloud.log No errors in nginx.log or PHP log or visible issues with installation.

Expected behaviour

Error doesn’t appear

Actual behaviour

Error | index | OCP\App\AppPathNotFoundException: Could not find path for spreed

Server configuration

Ubuntu 18.04
PHP-FPM 7.02

Nextcloud 15.0.4

Updated from an older Nextcloud/ownCloud or fresh install:
Fresh Install

Where did you install Nextcloud from:
Nextcloud Website (zip package)

Signing status:

Signing status

List of activated apps:

App list

Nextcloud configuration:

Config report

Are you using external storage, if yes which one: None

Are you using encryption: No

Are you using an external user-backend, if yes which one: None

Client configuration


Operating system:
Windows 10

Nextcloud log (data/nextcloud.log)

OCP\App\AppPathNotFoundException: Could not find path for spreed
/home/ - line 99:


/home/ - line 166:

OC\Core\Controller\SvgController->getSvgFromApp("spreed", "app-dark", "000")

/home/ - line 99:

OC\AppFramework\Http\Dispatcher->executeController(OC\Core\Cont ... {}, "getSvgFromApp")

/home/ - line 118:

OC\AppFramework\Http\Dispatcher->dispatch(OC\Core\Cont ... {}, "getSvgFromApp")

/home/ - line 47:

OC\AppFramework\App::main("OC\\Core\\C ... r", "getSvgFromApp", OC\AppFramew ... {}, { app: "spre ... "})


OC\AppFramework\Routing\RouteActionHandler->__invoke({ app: "spre ... "})

/home/ - line 297:

call_user_func(OC\AppFramew ... {}, { app: "spre ... "})

/home/ - line 987:


/home/ - line 42:


You should do a
sudo -u www-data php occ app:getpath spreed
to see if you get the same error.
As far as I know the app ‘spreed’ has been substituded by the app ‘talk’
In the app store you won’t find ‘spreed’ for Nextcloud 14 and 15, just for 13 and below.

Nope, running that command shows or returns nothing, just blank.

That means that ‘spreed’ is not installed, which should be OK since you are using 15.0.4. So maybe you should try again to get a response from the maintainers.

OK, it seems that the new app ‘talk’ is ‘intern’ still named ‘spreed’. So, did you install ‘talk’ or have you tried to install it? If so something went wrong and you should again try to install it.

I did not, the addon is disabled or never installed in Apps section.

Maybe you should install it and see what happens?