Applications installed but don't show

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): Nextcloud 21.0.3
Operating system and version (eg, Ubuntu 20.04): linux 3.10.0-962.3.2.lve1.5.25.10.el7.x86_64
Apache or nginx version (eg, Apache 2.4.25): Apache 2.4.48
PHP version (eg, 7.4): PHP 7.3.28

The issue you are facing:

i installed some applications today from the panel settings > apps, but none of them shows up in the top bar next to the one already and succesfully installed few days ago

they are shown as actives in my applications list, but i cannot use them since i don’t see them !

here is the list :

  • BPM files
  • collabora online (along with Collabora Online - Built-in CODE Server)
  • Mind Map
  • Ownpad

collabora fail to open when i click on a document, with an error message asking me to retry later

Is this the first time you’ve seen this error? (Y/N): Y

The output of your Nextcloud log in Admin > Logging:


The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'something', //transformed info
  'passwordsalt' => 'something', //transformed info
  'secret' => 'something', //transformed info
  'trusted_domains' =>
  array (
    0 => 'my_nextcloud_url', //transformed info
  'datadirectory' => '/home/name/nextclouddata', //transformed info
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'https://my_nextcloud_url/nextcloud', //transformed info
  'dbname' => 'something', //transformed info
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'something', //transformed info
  'dbpassword' => 'something', //transformed info
  'installed' => true,
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 2,

The output of your Apache/nginx/system log in /var/log/____:
there is nothing in /var/log/


Not all applications are supposed to put an icon on the top. Typically, file-based applications do NOT, rather they would be activated as needed in the appropriate location in the directory tree. Collabora in particular (because I’m familiar with that and not the others) definitely does not add an icon in the top bar.

An application needs to specifically implement a top bar button in order for it to be added there.

For your error with collabora, there are lots of threads on the subject. You should do a search on the error.


thank you for the answer ! but then, how do you create a new document for collabora, from inside nextcloud ?

nevermind, that was obvious : i can choose to create a document when i choose the option + in file :slight_smile:

1 Like