Appending /download to shared files - unsuccessful download on Chrome Android

Here’s an example: https://demo.nextcloud.com/index.php/s/gmZEm3i00Dx3Qyr/download

What I get on Chrome for Android is:

(Ignore the window behind the error at the bottom, I have something else open in the “normal” shared link view)

The NC logs are clear, and I don’t see anything in Apache. The file downloads immediately and successfully from laptop/desktop no issue.

I don’t know what “server issues” could be.

What version of Chrome on Android are you using? Chrome 54 and newer should work reliably as Google fixed some bugs relating to the cookie handling there.

54.0.2840.85 so should be fine, but unfortunately not.

So it would appear my whitepaper on DDoS Attacks for O365 is very popular judging by the number of downloads… but I’m no closer to a solution here people :slight_smile:

This also seemingly affects any files downloaded via chrome on android, with or without using the /download option. Clicking the download all button or the 3dots then download arrow on an individual file got the same error.

Embarrassingly I’ve had to email some photos to family directly as they complained of “an error message” when I provided the link to a Christmas gallery; obviously visiting it from their phones.

@tflidd @LukasReschke any ideas?

I have no android device. You could try some compatibility mode (https://developers.google.com/web/tools/chrome-devtools/device-mode/). You can also try on demo.nextcloud.com

If all that fails, open a bug report.

https://demo.nextcloud.com/index.php/s/gmZEm3i00Dx3Qyr/download gives the same error. Glad it’s not just my server.

Bug report here we come… (because compatibility mode isn’t a solution).

It would be just a way to find out what the chrome browser on mobile doesn’t like or what actually fails. Server issues is indicating that the client is expecting something from the server.

OK, you’re right. Compatibility mode worked fine, downloaded the files without a problem.

:frowning:

Upgraded to 11, the same issue remains.