App store down - SSL Issue - NC Let's Encrypt SSL cert error?

Nextcloud version (eg, 12.0.2): 17.0.1
Operating system and version (eg, Ubuntu 17.04): Debian
Apache or nginx version (eg, Apache 2.4.25): Apache
PHP version (eg, 7.1): 7.1

The issue you are facing:

Hi - I was unable to load the apps pages from the settings pages like normal. Spins for a while but just stays a white page. Looking in forums for fix I saw to add the url to the config file. Before I did that I tried that URL in Fireflox and received an invalid security error saying the LetsEncrypt Cert on that server isn’t valid. I am assuming that’s the problem in my NextCloud install as well - it can’t reach the server.

Firefox shows:
Websites prove their identity via certificates. Firefox does not trust this site because it uses a certificate that is not valid for The certificate is only valid for

Then if I click for more details it shows:
Unable to communicate securely with peer: requested domain name does not match the server’s certificate.

HTTP Strict Transport Security: true

HTTP Public Key Pinning: false

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Go to app page in NextCloud - shows installed apps - but if trying to browse tool for more apps online - just shows white page.
  2. open firefox to see if server address is valid for that’s shown in documentation as the default.
  3. Receive invalid cert alerts from Firefox.

To be honest, I’ve never heard about adding this url to the configuration file. All my installations are running without this trick like a charm. Additionally is using a certificate which has been created for, so that a certificate error is an expected result.

hi j-ed - thanks for the response. Yes - I had never seen that in any of my config files either. I tried adding it and then removed it as I assume that’s part of the default as it always worked before. Can you confirm that your app store in the settings is working? Maybe the cert has nothing to do with it and it’s something else going on with my install?

Thanks for your time!

It might help to check related postings on this forum:

Thanks - rebooted my server and all is well now so closing post for now. No idea what was going on but appears to have fixed itself. Appreciate your efforts!

I had rebooted after the upgrade previously with no help - so not sure if that’s related or not… but maybe something didn’t complete before the upgrade?

The is not the correct host anymore.
Is has no valid SSL certificate if the certificate is forced accepted it will redirect to the german languave page.