App crashes when uploading images manually

Hi,

my girldfriend has a iPhone SE with latest iOS and latest Nextcloud App 2.14. ALl worked fine until I upgraded the Nextcloud Server last days from v9 to v10.0.1. Now if she tries to manually upload a file (image), the app closes (crashes) just after seleting the file from the file picker. Background upload seems still working.
I’m using the Windows Mobile Client to upload files, that works fine. Also the Webinterface works without problems. So I think this is a iOS Client related Bug.

Could you please take a look?

greetings,
André

@ios something for you?

1 Like

Mmmm very strange … logs on Nextcloud server with error ?

jep, you are right. This is the exception I’m getting in the server log:

Debug 	
webdav 	
Exception: {"Message":"HTTP\/1.1 404 File with name Noah2\/2016-11-22 18-10-09 3916.jpg could not be located","Exception":"Sabre\\DAV\\Exception\\NotFound","Code":0,"Trace":"#0 \/share3\/www\/3rdparty\/sabre\/dav\/lib\/DAV\/Server.php(903): OCA\\DAV\\Connector\\Sabre\\ObjectTree->getNodeForPath('Noah2\/2016-11-2...')\n#1 \/share3\/www\/3rdparty\/sabre\/dav\/lib\/DAV\/CorePlugin.php(334): Sabre\\DAV\\Server->getPropertiesForPath('Noah2\/2016-11-2...', Array, 0)\n#2 [internal function]: Sabre\\DAV\\CorePlugin->httpPropFind(Object(Sabre\\HTTP\\Request), Object(Sabre\\HTTP\\Response))\n#3 \/share3\/www\/3rdparty\/sabre\/event\/lib\/EventEmitterTrait.php(105): call_user_func_array(Array, Array)\n#4 \/share3\/www\/3rdparty\/sabre\/dav\/lib\/DAV\/Server.php(459): Sabre\\Event\\EventEmitter->emit('method:PROPFIND', Array)\n#5 \/share3\/www\/3rdparty\/sabre\/dav\/lib\/DAV\/Server.php(248): Sabre\\DAV\\Server->invokeMethod(Object(Sabre\\HTTP\\Request), Object(Sabre\\HTTP\\Response))\n#6 \/share3\/www\/apps\/dav\/appinfo\/v1\/webdav.php(60): Sabre\\DAV\\Server->exec()\n#7 \/share3\/www\/remote.php(165): require_once('\/share3\/www\/app...')\n#8 {main}","File":"\/share3\/www\/apps\/dav\/lib\/Connector\/Sabre\/ObjectTree.php","Line":173,"User":"userxxx"} 	
2016-11-23T09:42:15+00:00 	
userxxx

But the iOS app shouldn’t crash. Even if the server throws an exception. :wink:

No , isn’t normal !

Test with clear cache in Settings , if persist the problem Exit Nextcloud in Settings and then recreate account.

Send me report.

  • Cleared the cache (1.7 GB) -> tried to upload camera image -> crash

  • Removed user account, restarted the app, new login -> tried to upload camera image -> crash

  • deleted the whole app and re-installed from the app store, user login -> tried to upload camera image -> crash

Exception: {“Message”:“HTTP/1.1 404 File with name Noah2/2016-11-23 14-14-18 3923.jpg could not be located”,“Exception”:“Sabre\DAV\Exception\NotFound”,“Code”:0,“Trace”:"#0 /share3/www/3rdparty/sabre/dav/lib/DAV/Server.php(903): OCA\DAV\Connector\Sabre\ObjectTree->getNodeForPath(‘Noah2/2016-11-2…’)\n#1 /share3/www/3rdparty/sabre/dav/lib/DAV/CorePlugin.php(334): Sabre\DAV\Server->getPropertiesForPath(‘Noah2/2016-11-2…’, Array, 0)\n#2 [internal function]: Sabre\DAV\CorePlugin->httpPropFind(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))\n#3 /share3/www/3rdparty/sabre/event/lib/EventEmitterTrait.php(105): call_user_func_array(Array, Array)\n#4 /share3/www/3rdparty/sabre/dav/lib/DAV/Server.php(459): Sabre\Event\EventEmitter->emit(‘method:PROPFIND’, Array)\n#5 /share3/www/3rdparty/sabre/dav/lib/DAV/Server.php(248): Sabre\DAV\Server->invokeMethod(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))\n#6 /share3/www/apps/dav/appinfo/v1/webdav.php(60): Sabre\DAV\Server->exec()\n#7 /share3/www/remote.php(165): require_once(’/share3/www/app…’)\n#8 {main}",“File”:"/share3/www/apps/dav/lib/Connector/Sabre/ObjectTree.php",“Line”:173,“User”:“userxxx”}
2016-11-23T18:00:40+00:00

Problem : incorrect response of server

please wait for details

Any news about this? I send you a demo login to my server via email a week ago.

Sorry, no news, please open issue on github, the server respond incorrectly at call webdav readfile.

The Windows Client works great. What’s wrong with the server response? How should it look like?

Hi,

I don’t think that there is a wrong response from the server here. What is the response and what do you expect it to be, @ios ?

Morris

@MorrisJobke i except 404 file do not exists … but return 200 OK and no items, this is documentation driver ios owncloud, if items = 0 the app crash :

OK, should I open a server issue for it? @MorrisJobke @ios

Yes @SunboX ! Thanks

I’ve created an issue for that: https://github.com/nextcloud/server/issues/2874

1 Like