Any way to disable the link preview?

In our collective there are links within paragraphs that link to other collective documents. When using simple links or link picker the link displays as the URL or the URL with a preview, breaking up the flow of the paragraph. Is there a way to control this behavior and have a link to a Collective page display as just a normal link text?


Would like to know that, too!

I would like to create a wiki like collective with links to articles in sub-pages. So the link preview or the URL is disturbing

i am interested too

Vote for this issue (add your thumbs up):

re: privacy … Currently there is a config option to prevent the server from trying to fetch an opengraph preview:

re: UI/UX … Unfortunately, the paragraph flow is still broken up:


Allways then, when the text ends with the link, the preview is visable.
Simply hitting enter, so your cursor is under the preview and delete the preview backwards wil remove the preview but only as long as you are in edit mode, The preview will come back when editing is finished.
To prevent this behavior, simply continue with text behind the link, as soon as there is a space with folowing text, the preview disapears (and doesn’t come back).
So this would do the trick: .

as you can see, there is a space after the link and then a single dot. That is enough, to keep the preview away.

If you want to edit your markdown syntax, like [text](link) instead of <link>, you have to use Plain text editor - files_texteditor in combination with Markdown Editor - files_markdown

Therefor you must exit the Colectives App, go to your Collectives Folder in the files App and choose image. After that you have to open the text app again, which then asks whether you want to use the saved or the old version. Then you select the right version, that is the one you just edited with the plaintext editor.
Unfortunately plaintext editor doesn’t handle multibyte characters like emojis properly. So they all break, strange characters appear in their place, which then have to be “repaired” after each external processing. Yes, it’s really awful!

Hope this helps.
much luck!

1 Like

Excellent, thank you!

1 Like

For me is enough (probably wonderful) the trick of the final dot !! So, in this way i can control when disable de preview generation depending of the context.
Thanks!! :heart: :heart: :heart: .

1 Like