Android nextcloud client crashes when trying to set up client

I am trying to set up the nextcloud client on lineageOS; I have done this a few times on different systems, always worked. But now I simply experience that after entering user name and password, the app crashes. Any suggestions for how to explore/repair this?

Remove app/re-install does not help.

Are there, maybe, any files I could remove?

The owncloud client works flawlessly for the same account.

hmm, solved by reinstalling lineageOS completely after noting that other apps had resonating problems.

1 Like

Hi @ilippert, great you got it fixed. We are aware that LineageOS user experience this sometimes since (for whatever reason) the user database gets corrupted a bit and so the Nextcloud client crashes when trying to access/read the user from the database. :confused:

actually, I am currently guessing that the cause for my experience might have been installing Orbot/Orfox. When NOT installing these apps, then I was able to use Nextcloud client app as well as other apps that wanted to store user login data somewhere.

Interestingly - maybe: the nextcloud notes app was not affected by the issue at all.

I have exactly the same problem on my Lenovo A4 10 Tablet. So it is not limited to LineageOS.

It used to work at the begin, then suddenly all accounts were removed (I have two different Nextcloud servers). When I try to reconfigure the accounts, it crashes at the end, after checking user name and password. The accounts are not stored, Nextcloud client starts again with the initial create-account-screen.

Removing Orbot and Orfox did not help. But it used to work, as far as I remember, before I installed Orbot and Orfox.

Also special in my installation: I have removed or disabled most bloatware apps, especially all Google stuff, including «Google App», «Google Play Store» and «Google Play Services». But Nextcloud client used to work for a while, even with those already deactivated. So I think Nextcloud client should not depend on any of those?

On my old tablet, I had Orfox and Orbot installed alongside with Nextcloud client with no problems.


  1. Can you reproduce the problem?
  2. May I help, i.e. are there any log files I could send you?

Oh yes, Nextcloud client failed after starting to synchronize a large directory (several GB). Then I installed Nextcloud Dev client and it used to work! Even though Orbot/Orfox were installed. But only until I started to synchronize the same directory again.

Unfortunately, I really need those data locally!

Now: Nextcloud and Nextcloud Dev client both fail as specified above, even though I uninstalled them, removed all data, the downloaded data and even the folder using a filemanager. After reinstallation, both still fail!

Any solution?

Upgrade to Nextcloud server 14.0.1 did not help. :frowning:

@mrw can you check if the accounts of Nextcloud still show up in the Androids settings for accounts and if so, remove them too.

Other than that that if the issue still occurs we might need the logcat when this happens.
Best is also to post this to the Android client’s issue tracker on Github to reach all the developers of the client.

Hi there, from what i read i seem to have the exact same issue as described above. Was there a solution found or can i provide something to help solving it?