Android Client 3.19.1 - Grant Access Issue - What I've Tried [fixed]

Hi,

I’ve been using NC successfully for a number of years (snap), but recently I decided to reinstall the Android App from F-Droid to be sure I’m using the correct one.

I am running behind PFsense using HAProxy to offload SSL, and it was working and the desktop and web clients are still working fine.

However I can’t get past Grant Access in the Android App and I’ve tried everything I can find including:

‘csrf.optout’ =>
array (

4 => ‘/Nextcloud-android/’,
),

‘trusted_domains’ => array ( 0 => ‘myserver.mydomain.com’, )
‘overwrite.cli.url’ => ‘https://http://myserver.mydomain.com’
‘overwriteprotocol’ => ‘https’
‘overwritehost’ => ‘myserver.mydomain.com

I’ve also cleared Android Cache and Data.

but I can still not connect. I have tried regular login and app password login.

Please could someone point me in the right direction, where to look? This configuration worked fine when I installed in the v19 timeframe, so I think it must be due to a config change probably for security purposes, but I can’t find it!

Regards
Ian

Hi Ian,

I’ve got exactly the same issue, were you able to get this resolved? I’m tearing my hair out, after upgrading to 23.07.