Android App Will Not Automatically Upload Pics or Vids

https://github.com/nextcloud/android/blob/auto-upload-apk/apks/android-debug.apk?raw=true

Try this one. :slight_smile:

I’ll give it a shot and see anything changes.

Edit: After uninstalling the PlayStore version, the beta and the debug version you gave me both auto-uploaded my files. It looks as though my pictures where being uploaded in the background as well in one of the apps as some of my photos from yesterday are now showing up on my server.

On the other side though when I tell Nextcloud to delete the file after it’s uploaded…it never does. It hasn’t done this in all the time i’ve used it.

The “delete after upload” is a whole other issue. If you install the new APK (from the same link) it should be fixed.

Let me know! :slight_smile:

With the new apk, it still stays in the phone. Delete after upload isn’t as big of a concern as long as it auto uploads. What causes the issue with the delete function after it’s supposed to upload?

I don’t know - investigating. Will have a new APK for you in a few minutes :slight_smile:

Please try now.

Same as before, no delete function.

Thanks. Will keep this in mind.

Same for me
Nextcloud Server 11.0.2 (stable) on Arch ARM running on Raspberry Pi 2
Nextcloud Android-App 1.4.1 (Downloaded from PlayStore)
Moto Z Play Android 7.0

No beta option on playstore

The newes beta (20170301) does the uploading

On of the February Betas fixed that also for me, except that it now tries to upload very very old fotos from time to time. But no only ones rather everytime the same photos and just adding a “(1)” at the end of the file name :frowning:

The latests beta should not do that and also we did the release of 1.4.2 RC2 on the tester channel on Google Play yesterday.

1.4.2 RC2 uploaded multiple screenshots, but blocks screenshoting the app itself


(the first notification tells “screenshot not possible, the app or your company forbids taking screenshots”)

Is there a setting option for that?

No there’s no setting for that. NC does nothing but monitor folders for files.

Is your device managed MDM or personal?

Can you provide device details?

1 Like

As Jason said must be something else since I just checked and can take screenshots. Also like he mentioned we don’t have any blocking mechanism implemented.

Android Device Manager is activated


and my phone is synced with my googleaccount, but was set up as new device (i didn’t use the device settings of my last android device)
I use the moto z plays stock rom at android 7.0

[EDIT]
as I figured out right now, its triggered by activating pin

The nighlty works good.

1 Like

I fixed it by browsing android Settings -Account - Nextcloud Enable/Disable - Sync

using nightly build, my app shows waiting for upload, but I found out, that it’s crawling through the whole folder structure on background:

IP - danman [27/Mar/2017:15:13:46 +0200] "PROPFIND /remote.php/webdav/FOTO/... HTTP/1.1" 207 24618 "-" "Mozilla/5.0 (Android) nextcloud-android/20170317"
IP - danman [27/Mar/2017:15:13:47 +0200] "PROPFIND /remote.php/webdav/FOTO/... HTTP/1.1" 207 2257 "-" "Mozilla/5.0 (Android) nextcloud-android/20170317"
IP - danman [27/Mar/2017:15:13:47 +0200] "PROPFIND /remote.php/webdav/FOTO/... HTTP/1.1" 207 84495 "-" "Mozilla/5.0 (Android) nextcloud-android/20170317"
IP - danman [27/Mar/2017:15:13:50 +0200] "PROPFIND /remote.php/webdav/FOTO/... HTTP/1.1" 207 2226 "-" "Mozilla/5.0 (Android) nextcloud-android/20170317"

Why is this necessary??

I cannot get the automatic upload to work either. I am running the latest stable nextcloud server 11.0.2. My phone is a Galaxy A3, Android version 6.0.1.