Android App Will Not Automatically Upload Pics or Vids

I switched to the Nextcloud Android client from the Owncloud Android client about a month ago when I migrated my server to Nextcloud. This month, I noticed that none of my pics or videos I had taken since I started using the Nexcloud app had uploaded to the Nextcloud server automatically from my phone. I verified that I had the auto upload option selected for both pics and vids and that I had selected “Upload on Wifi only” option selected. I also verified that the path on my Nextcloud server that I had selected for pics and vids existed. Everything looked fine. Took a pic while on Wifi. No upload within a few minutes. Forced closed the app. Tried again. Did not work. Rebooted the phone. Tried again. Did not work. Cleared the app cache. Tried again. Did not work. Uninstalled the app. Reinstalled the app. Setup the options. Tried again. Did not work. So I uninstalled the Nextcloud Android app and installed the Owncloud Android app. Setup the options. Took a pic and BAM! It uploaded it to the Nextcloud server instantly. So something is wrong with the Nextcloud Android app (version 1.3.1).

I think that this might be an issue with Android 7.0. I have a Nexus 5x phone that updated to Android 7.0 around the time that the Nextcloud app stopped working. I can’t verify for sure because I don’t know the exact date that my phone updated to Android 7.0. If this is the case, then there might not have been any cases of people complaining about this issue yet since the number of Android devices with 7.0 is like .000005% of devices at this point.

Looking to hear your opinions.

Brian

PS Just fired up my old Nexus 5 phone running Android 6.0.1, installed the Nextcloud client, configured the settings exactly like the Nexus 5x, took a pic, and voila! the Nextcloud app uploaded the pic instantly. I think that there is an issue with Android 7.0 and the current Nextcloud Android client (1.3.1)

BTW. I’m running Nextcloud 9.0.53.

Hi @scoobybri - That is exactly the case. The Android client doesn’t yet support Android 7 (I am also using a Nexus5X) but this is something we are working on: https://github.com/nextcloud/android/issues/285 and want to have this integrated into the next release 1.4.0 (if possible).

@scoobybri IN around 24H

IF you have some time to spare you can download and install/test the (upcoming) beta app (like before it can be installed in parallel to the stable release) https://f-droid.org/repository/browse/?fdfilter=Nextcloud&fdid=com.nextcloud.android.beta

The next beta release with the new Instant Upload feature I mentioned will be available in about 24h +/- some hours. Beware though that this is a completely new implementation of the instant upload so this is truly beta So bug need to be expected and if they occur please report them on our issue tracker https://github.com/nextcloud/android/issues
Thanks for your patience with the instant upload and any help testing this new feature. Hint… It’ll be way more than just “camera” :wink:

i have the sams issue with nextcloud client.

the nextcloud logfile is full of these entries:

I’m running Android 6.0.1 AOSP based.

@Lars_M what do you see on the client side?

I make few Screenshots
the Folder on the server exsist. WiFi running but the App won’t upload anything when I make an Screenshot or Photo.


the logfiles are empty. also on the server.

:confounded: cc @tobiasKaminsky since you might be the better one to talk to for this matter. The screenshots should work … (tested it on my phone Android 7.1.1 / Nexus5X). Which version of the beta are you running?

I have create an Logfile and deviceinfo file…

11-07 13:32:54.916 I/ActivityManager(3694): Process com.nextcloud.android.beta (pid 1942) has died
11-07 13:32:54.916 W/ActivityManager(3694): Scheduling restart of crashed service com.nextcloud.android.beta/com.owncloud.android.services.observer.SyncedFolderObserverService in 1000ms
11-07 13:32:54.916 W/ActivityManager(3694): Scheduling restart of crashed service com.nextcloud.android.beta/com.owncloud.android.services.observer.FileObserverService in 1000ms
11-07 13:32:55.932 I/ActivityManager(3694): Start proc 21350:com.nextcloud.android.beta/u0a271 for service com.nextcloud.android.beta/com.owncloud.android.services.observer.FileObserverService
11-07 13:32:56.168 D/ThumbnailsCacheManager(21350): create dir: /storage/emulated/0/Android/data/com.nextcloud.android.beta/cache/thumbnailCache
11-07 13:33:35.030 V/ConnectivityActionReceiver(21350): component: ComponentInfo{com.nextcloud.android.beta/com.owncloud.android.files.services.ConnectivityActionReceiver

https://cloud.land-laeufer.de/index.php/s/gbumnJ7TX7mpGe3

the beta is 20161027
Android 6.0.1

Hi @Lars_M
The link give me a

Memcache \OC\Memcache\APCu not available for local cache Is the matching PHP module installed and enabled?

The latest beta version is 20161107

yes, APCU is installed now and it works. I made an test today and the nextcloud picture upload works. but not with the Beta App.

Hi @Lars_M with which version of the client is the picture upload working? Or do you mean a manual picture upload?

with the latest Playstore Version the Upload works. (Version 1.3.1)

@Lars_M Yes, that is likely due to the fact that 1.3.1 uses the “old” mechanism which will not work on Android 7+, while the beta already ships the new mechanism which still has some bugs/quirks that need to be resolved before we ship the next stable/RC or just activate it for Android 7+

1 Like

thanks for your answer, I wait for an stable release…

Just for playing around and having some fun, the beta app can be installed in parallel :smiley:

yes I know. the multible folder upload function is cool.

I’ve got a similar problem on Cyanogenmod 13 (which I think is not Android 7 yet, right? Pics and vids just won’t upload. The server is normally accessible, no relevant logs on the server side, dunno if the client produces any logs.

@eischmann CM13 is Android 6 afaik, the client should produce logs in case ob the beta app (available on f-droid), logs accessible via the settings screen (at the bottom). We do have some logging issues on different devices but it might be worth a try (+ the beta app can be installed in parallel to the stable release).

i had an Update today. i try to upload Pictures with the Uploader, when i´m at home. I give Feedback if this work now.

1 Like