Android app ssl initialization failed

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version: 18.0.4
Operating system and version: FreeBSD 11.3 (FreeNAS Jail)
Apache or nginx version: Apache/2.4.43 (FreeBSD)
PHP version: 7.3

The issue you are facing:
Since upgrading to nc18, it seems I have an issue getting the android app to work via my configuration with HAProxy (on my pfsense FW). Every time I try to upload something via the app I get SSL initialization failed. Going to NC via the browser works fine and shows no errors. If I bypass the HAProxy via the app it works as well.

Is this the first time you’ve seen this error?: Y

Steps to replicate it:

  1. Configure HAProxy as a reverse proxy with SSL offloading
  2. Try to upload a file

Did you check your SSL configuration with https://www.ssllabs.com/ssltest/ ?

All good with an A+ score.
I did see a couple of posts regarding a setting for the ecdh curve and that it needs to be set to prime256v1 but no matter how I tried to configure it on the HAProxy, nothing seemed to worked.