Android app fails with "Unknown error", web works great. Tried most fixes

Hi all, I’ve got nextcloud running nicely on an OdroidXU4. Suddenly the Android client will not allow connections but simply gives unknown error.
I’ve cleared my bruteforce table and can easily access the web interface, webdav,caldav as well as the status page of my server. Caldav syncs properly with my phone using DAVDroid.
No logs are produced from the connection attempts (afaik).

What URLs would the android app be checking, so I can try them manually?
Any help welcome.

Nextcloud version : 12.0.2
Operating system and version : Debian Jessie
Apache or nginx version : Nginx
PHP version : 5.6.3

Can you reliably replicate it? (If so, please outline steps):
Install nextcloud app 1.4.2 or dev app 1.5.0, enter url of Nextcloud install and wait for the app to test connection.
The issue you are facing:
Connection test will fail with “Unknown error”

The output of your Nextcloud log in Admin > Logging:
No logs produced on connection attempt.

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

The output of your ngnx log:
Tailing error and access logs show other events, but no output while attempting to connect android app.

cc @mario @tobiasKaminsky - you might have the time to debug/support?

Are you trying to connect from same network? I had same error when connection come from external network via port forwarding.

Thanks for the hint.
Both external and internal networks, DNS internally resolves to internal IP.

Still struggling with this unfortunately.