Android app cannot connect to server!

Hello All,

I have been using nextcoud in Synology for few weeks. I have read other forum about an android app not connecting to the nextcloud server. They have mentioned the issue is with ipv6 address, but I do not have any ipv6 address. I do not know how to make it work.

Problem Description:

1. Server Description:
I do not have much idea, but I am running 10.0.1 (stable). I have a domain “” SSL certified by COMODO RSA, and nextcloud is hosted at Port is forwarded to WAN. If you need more information, please let me know.

2. The connection from my LAN: Nexus 5X results!

3. The connection from WAN: Nexus 5x results from my university and 4G

From many other posts, I saw that the issue was with an IPv6 address. I checked with “”, and I do not have any working IPv6 connection. Since demo works, I am sure some configuration is wrong on my server side, but I am not able to figure out the issue.

Please can anyone help me?

can you mail me your server address to I just want to connect with my app while debugging the connection attempt.

But indeed, this is strange.

I just sent you an email. !!

So…I did some tests:
Nexus 4, Android 6: works without problems
Emulator, Android 7: first it did not work, while debugging it step by step it suddenly worked.

All I did inbetween was to manually open in chrome on the emulator.

I am clueless. Is this apache? A vserver?

From my understanding I am using web services of Synology. i think they use Apache and I do not know what is vserver.

Is there a way to figure out if it is vserver or apache? And how are you able to connect to the server? I am not sure how you did that.

vServer is a virtual hosted server in a cloud computing center. As you mention synology, which is a NAS(?), you do not have this :wink:
How I connect to your sever: I just checked if I get an error while connecting the app. First it shows “connection timed out”. After my various tests it shows “connection established”. Nothing more :wink: So all save :wink:

I think, I figure out the issue. It was network configuration. My server has two ethernet ports and I forwarded my wan ip to By default, my default gateway is, i changed it to and now it works. Usually, for all of my other web services previous configuration was working but nextcloud.

Thankyou for helping! :slight_smile:

Ok, It was just a temporary fix. The app is working weird. It sometimes connects to the server and sometimes doesn’t. Now I am not able to access the server from the app with my domain whether it is LAN or WAN. However, accessing from web works. No idea where is the issue.

Maybe it is better to ask the server guys here:
Maybe they have an idea how we can solve this.