"An unknown error has occurred" when uploading files larger then 1M

Hi Community.

I’m having trouble uploading files larger than 1M.
i get this ERROR “An unknown error has occurred”.
i fixed the /etc/phpx.x/apache2/php.ini file (upload_max_file_size & post_max_size)
The problem remains !!!
Is there anything else to change?


Hi @Eniac,
Have you some log about this error ( nextcloud log / apache log or other ) ?

Hi Mageunic,
thanks for the reply.

I checked the logs, nothing useful .

@Eniac do you use any nginx reverse proxy on your nextcloud web page?

Thanks for your time.
I thought I might make a mistake when installing Nextcloud on LAMP.
That’s right, I have ReverseProxy. I disabled it and now it works.


@Eniac if it is a nginx reverse proxy , you have to edit your reverse-proxy.conf, add this :

client_max_body_size size;
replace size with a number like 1m

It’s a UTM device.
Thanks again for your time and help.

1 Like