An error occured during the request. Unable to proceed. Couldn't update app

Happy Holidays everyone; I am having issues with upgrading my apps I am running Nexcloud 19.0.4 on to of Ubuntu-Server When I click on the upgrade button in Nextcloud, it ask for my password. it look like it about to run then I get this error: *An error occured during the request. Unable to proceed. Couldn’t update app. I never had a problem like this before. See attachment,
Also where are the log file for Nextcloud, I look in the /var/logs, I may have miss it but then again I was look for Nextcloud.


Thanks :+1:

1 Like

Hey eredwood007,

I’ve been experiencing the same issue with my Nextcloud instance for a couple of months now and have just managed to resolve today. I’m running 20.0.4 on ubuntu 20.04 but was having the issue before attempting a version upgrade ( from Nextcloud 19.0.4).

In my case, once I finally managed to get OCC running from the Bash, I was able to shift the service into maintenance mode then run an update on all applications. My Mail application bombed out, but I was able to launch the update command again, and it finished without issue.

To get it running in maintenance mode I ran the command;

sudo -u www-data php /var/www/nextcloud/occ maintenance:mode --on

followed by;

sudo -u www-data php /var/www/nextcloud/occ app:update --all

to perform the updates.

Once I turned off maintenance mode (–off), launching Nextcloud from the browser saw me needing to complete an update, which was for the Mail app (that failed) but after that everything was good again. I can now manage apps through the portal just like before.

I hope this helps or offers you some direction.

Good luck :+1:

1 Like

Hi eredwood,

Did you sort this out? I only ask because I had roughly the same problem but wasn’t able to use the occ command. I used the workaround given by Hauke Plambeck in the other thread where you posted about this : Stuck in Maintenance mode, though according to config file not - #20 by Hauke_Plambeck

I found my config.php file, changed Maintenance => true to false and the whole process revived and resolved. If Smakdab’s rxcellent solution isn’t right for you, this might be a last resort.

I had a sweaty half hour searching for solutions, so it was a big relief! I’ve come to depend on my Nextcloud server. I hope it’s all worked out for you.

Thank you for your reply [Smakdab]. But what I did was disable the program and then the update went though. I did not ask any question just happy it worked. I am good to go.

1 Like

Thank you for your reply [danceswithcats]. But what I did was disable the program and then the update went though. I did not ask any question just happy it worked. I am good to go.

I did not forget you in this matter, I want to take a time out and thank you for your responses. I really love working with nextcloud and the community. I just hate it sometime when I finally get NC setup and Boom there a problem with the updates. This issue really caught me off grad. I hate to say it but sometimes I wait at least 30 to 60 day on the big updates. I fear that it will break something, or worst yet the program want let me back out of the update and have start all over again. I am running NC 19.04 and right now I am good. What version are you working with and have you upgraded to NC v. 21 yet.
Again Than you.

Hi eredwood,
That’s really nice. Thank you. This is one of the nicer forums, I think, a bit closer in tone to how the major Linux OS forums used to be until they all got a bit elitist a few years ago.

I’m on 20.0.8, and Nextcloud isn’t, at the moment, offering me an update. I am very cautious about updates. I don’t have the technical depth to find workarounds for bugs, and so have, for years, stuck to long term support releases of operating systems, which I only install after the first major post-release update. I apply that same caution to Nextcloud. As a rule, I update when I’ve seen enough people on the forums are not posting problems. I know that one of the issues that can derail an update is if the servers are too busy - if too many people are downloading the update files at the same time, so I tend to wait until the fuss has died down.

I am, very nervously, planning a reinstall at some point, however. At the moment, my NC is on a little Lenovo desktop, a Tiny, just on a simple Debian server, which it is sorely underusing. It is also the only domain I can access on my network from outside. I would like to reinstall, using YunoHost, as I am not confident about DNS and all that stuff, and that platform automates that. The aim is to have Nextcloud, a small media server and a static website running a blog all on the same machine, using my home samba server as storage. I’ve already transferred my samba server to a Raspberry Pi, linked to a 10TB external hard drive, and the smoothness with which that went has emboldened me, so I’m hoping I’ll have a clear weekend soon.

Hi, I’m having the same issue, where I can’t update any of my apps. I have tried both in and out of maintenance mode, and both the Admin portal, and the occ command line, but nothing works. However when I try to install a NEW app, I get a curl error, about the SSL cert. cURL error 60: SSL certificate problem: unable to get local issuer certificate (see . When I google the error, a lot of people are trying to use a self-signed cert, and that ends up being the problem. But our cert is from Digicert, so I know that it’s valid. Anyway, I’m wondering what you mean when you say you “disabled the program.” Do you mean you put it into maintenance mode, or something else? I’m at my wits end here.

Environment: Ubuntu 18.04, PHP7.2.24, and Nextcloud 18.0.14

Thank you in advance for any insight you can provide!

I have a Dell Optiplex 990 i7 Desktop, I am using that as a Ubuntu Server 18.04 STL. with an 6TB Drive I am still on 19.04. I will try to up grade to next level soon. Again thank you for you time.