Always prompting "Authentication required"

Nextcloud version (eg, 10.0.2): 11.0.1
Operating system and version (eg, Ubuntu 16.04): ? (OVF-Template)
Apache or nginx version (eg, Apache 2.4.25): ? (OVF-Template)
PHP version (eg, 5.6): 7.0.13
Is this the first time you’ve seen this error and can you replicate it?: yes

The issue you are facing:
When I will change some settings (e.g. default quota for users) I’ll get a prompt for a password.
After entering my or the ncadmin’s password nothing happens but the prompt comes again

I’ve the same Problem. The admin passwords doesn’t work in all admin accounts

Ubuntu 16.04
Nextcloud 11.0.2
PHP: 7.0.15

Same here today. Any answers?

My ntp Client wasn’t working properly and so my system time was wrong. I restarted ntp service and now nextcloud accepts my passwords again.


1 Like

I re-installed nextcloud from scratch. (This was only a test server). I noticed when I got the initial web page to setup the database I was still creating the sql database manually and then adding the newly created nextcloud user and database name. This isn’t the current instructions, so this time I put in the sql root user and password and it worked! Authentication password works now when enabling apps.

Just an update. As it didn’t take long I repeated the re-install setting my vm back to before I had installed nextcloud, to check I didn’t miss any steps, following the install as per my notes. I was being careful to set the sql database as version11 install instruction detailed. However, this time I’m back to the Auth required pop-up when enabling apps. It says failed if I put the wrong password and just re-pops up, when I put the right password I don’t get the warning, but it re-askes to auth.

Fixed it. :slight_smile:

I missed an important part that is so obvious now. Part of my install of nextcloud is to edit the config.php so it can access samba users. Previously I used to access Unix users within a certain uid range. The default admin account created by nextcloud during the install was separate and never tied in anything other than nextcloud. This is my first taste on implementing both SambaAD and then nextcloud. I got caught when I edited the config.php file to allow SambaAD users to log into nextcloud. Worked grea. However, now the nextcloud admin account was looking at SambaAD for auth, strangely I could still login at the web standard login, but once in anything that needed auth would silently fail.

The fix was to add an admin user in samba AD, simple.

It would be nice if this next cloud account “admin” could be independent, or an error message that helps explain the issue.

Here is the only error I had, that stopped as soon as I added the admin account in Samba:-

internet_connection_check GuzzleHttp\Exception\RequestException: cURL error 60: SSL certificate problem: certificate is not yet valid

This error took me down so many dead ends and wild goose chases.

Hopes this helps someone else.

This is correct. I encountered the same problem and noted that the date on my Linux Server was 2 days off. I issued the command (Linux) ntpdate and had to reenter my Nextcloud appliance. The login messages disappeared.