AIO with Environmental Variables for derived containers

Dear community,
I have been trying to get the Nextcloud AIO to work properly for some time now. The normal installation works without any problems - even using an nginx-reverseproxy (defined in the same docker-compose-file).
When creating the necessary and optional containers (I call them derived containers, e.g. aio-collabora), the first errors occur because these containers do not get internet access, as I have to go through a proxy within the university network.
Usually, a few environment variables are set in docker-compose.yaml and that’s it. But this is not possible due to the architecture.
Can someone help me here, please? I have already tried to set these manually for the individual containers (e.g. via /etc/profile.d/ script) but without success. I also tried the manual installation of nextcloud-AIO - also with a frustrating result.
To be honest, I don’t think I’m the first one facing this problem… Am I too stupid to search adequately or is the problem solved by a trick I can’t find.

As the post here suggests, I’m at the end of my rope and would be grateful for any advice.
Thanks a lot

PS: I have of course made the proxy configuration of the docker client (~/.docker/config.json) and one could assume that the setting works for all - also derived - containers… but nope :frowning:

Hi, did you already check if you can make it work with

Hey Simon,
yes, I tried it with the manual installation – the nginx-configuration seems to be the problem.
However, I really cannot imagine, that I am the first one facing this problem. :open_mouth:
Do you think, I can get it with the manual installation? Shall I fix the difficulties with nginx?
Kind regards

If the problem is with nginx cant you fix nginx instead?

Indeed, I could try this again, but there should be a possibility to adjust/add the env-vars when the container has been initiated as it is done by the aio-mastercontainer.?
I could have pulled my hair out :open_mouth:

Why should we add this if it is an nginx problem?

I think we are misunderstanding each other: the problem with the nginx configuration is due to the requirements of my university - I have to use certificates and only the 2 ports: 80, 443 are available to me. Moreover, it is only a problem with the manual installation. I haven’t put that much time into it yet, because the standard installation of AIO works, only the ENV-VARIABLES are not transferred to the derived containers for the proxy settings, but they are absolutely necessary so that, for example, the container aio-collabora gets access to the Internet.

So I could imagine 2 relatively simple solutions:

  1. one could add an env-variable (in the present case “http_proxy”) of a container instantiated by the aio-mastercontainer - would be a docker problem
  2. the env variable is passed when the derived container is instantiated by the aio-mastercontainer

Sorry if I’m making this sound too simple or my requests sound presumptuous.

best regards

What kind of manual installation are you referring to? You mean not using AIO?

I would recommend to use if you need to adjust ENV for other containers which you can.

I meant the aio installation. Worked everything except of onlyoffice. It has again no internet. Do you have any advice and which output should be uploaded?