AiO: SKIP_DOMAIN_VALIDATION=true not working with docker compose

I am trying to install Nextcloud AIO v7.7.1 with docker compose in Ubuntu 23.10.

I have opened port 443 for both UDP & TCP in my router.

portchecker.co is showing the port is open.

But when I try to enter my domain name it keeps saying that port 443 is not reachable.

I have added “SKIP_DOMAIN_VALIDATION=true” to my compose file, but still it doesn’t help:

#Nextcloud AIO stands for Nextcloud All-in-One and provides easy deployment and maintenance with most features included in this one Nextcloud instance
  nextcloud-aio-mastercontainer:
   image: nextcloud/all-in-one:latest
   init: true
   restart: unless-stopped
   container_name: nextcloud-aio-mastercontainer # This line is not allowed to be changed as otherwise AIO will not work correctly
   volumes:
     - nextcloud_aio_mastercontainer:/mnt/docker-aio-config # This line is not allowed to be changed as otherwise the built-in backup solution will not work
     - /var/run/docker.sock:/var/run/docker.sock:ro # May be changed on macOS, Windows or docker rootless. See the applicable documentation. If adjusting, don't forget to also set 'WATCHTOWER_DOCKER_SOCKET_PATH'!
   ports:
     - 80:80 # Can be removed when running behind a web server or reverse proxy (like Apache, Nginx, Cloudflare Tunnel and else). See https://github.com/nextcloud/all-in-one/blob/main/reverse-proxy.md
     - 8080:8080
     - 8443:8443 # Can be removed when running behind a web server or reverse proxy (like Apache, Nginx, Cloudflare Tunnel and else). See https://github.com/nextcloud/all-in-one/blob/main/reverse-proxy.md
   environment: # Is needed when using any of the options below
      - NEXTCLOUD_DATADIR=$NCDATA # Allows to set the host directory for Nextcloud's datadir. ⚠️⚠️⚠️ Warning: do not set or adjust this value after the initial Nextcloud installation is done! See https://github.com/nextcloud/all-in-one#how-to-change-the-default-location-of-nextclouds-datadir
      - NEXTCLOUD_ENABLE_DRI_DEVICE=true # This allows to enable the /dev/dri device in the Nextcloud container. ⚠️⚠️⚠️ Warning: this only works if the '/dev/dri' device is present on the host! If it should not exist on your host, don't set this to true as otherwise the Nextcloud container will fail to start! See https://github.com/nextcloud/all-in-one#how-to-enable-hardware-transcoding-for-nextcloud
      - SKIP_DOMAIN_VALIDATION=true
volumes:
 nextcloud_aio_mastercontainer:
   name: nextcloud_aio_mastercontainer # This line is not allowed to be changed as otherwise the built-in backup solution will not work

Did you stop, remove, and recreate the container as noted in the documentation?

The port check doesn’t run if that variable is active.

What is the precise error message?

1 Like