AIO Restore from Backup: Operation not permitted

Nextcloud version (eg, 20.0.5): All-In-One v17.12.0 (and v17.11.2)
Operating system and version (eg, Ubuntu 20.04): Gentoo
Apache or nginx version (eg, Apache 2.4.25): AIO
PHP version (eg, 7.4): AIO

The issue you are facing:

I’m unable to restore a backup made using AIO 17.11 (fedora) to gentoo (aio 17.12). The fedora installation has selinux enabled, the gentoo installation does not.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Backup from a working installation (Fedora silverblue)
  2. Copy backup to a new installation on Gentoo
  3. Choose most recent backup and enter password
  4. Observe in logs, for hundreds of files:
rsync: [generator] chown "/nextcloud_aio_volumes/nextcloud_aio_nextcloud_data/USERNAME/files/Photos/InstantUpload/IMG20230901095315.jpg" failed: Operation not permitted (1)

The output of your Nextcloud log in Admin > Logging: No logs from admin panel, Unable to restore backup. see above

Hi, this looks like a permission issue either caused by incorrect permissions on your host or SELinux being enforced?

makes sense. i ran this rootless as a systemd quadlet container from the user home dir on the fedora server. i’ll take a backup and try chown -R’ing the data dir

1 Like

SOLVED: chowning the existing data dir did not work, but deleting it did. After (backing up, then) rimraffing the ncdata directory, borgbackup did not report any errors

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.