I am using Nextcloud AIO in the lastest version Nextcloud AIO v11.3.0.
Since the latest two updates I face a small, perhaps cosmetic problem with the installation. In the Nextcloud AIO interface, where the several containers are listed, all containers are shown as “running” (green), except Notify Push, which stays at “starting” (yellow).
When I check the logs of “Notify Push” container, I see:
2025-07-11T12:50:06.926685232Z Waiting for Nextcloud to start...
2025-07-11T12:50:11.928402628Z Waiting for Nextcloud to start...
2025-07-11T12:50:16.930241430Z Waiting for Nextcloud to start...
2025-07-11T12:50:21.932402002Z Connection to nextcloud-aio-nextcloud (172.16.4.6) 9001 port [tcp/*] succeeded!
2025-07-11T12:50:21.933826393Z notify-push was started
2025-07-11T12:50:21.976453513Z [2025-07-11 14:50:21.976246 +02:00] ERROR [notify_push] src/main.rs:84: Self test failed: Error while communicating with nextcloud instance: error sending request for url (https://<redacted>/index.php/apps/notify_push/test/version)
Any advice appreciated.
airflow
Hi, have you already tried to reboot the server?
I just tried that, but it didn’t change the behaviour. 
Hm… Can you post the output of sudo docker info here?
Sure thing!
root@fractal:~# sudo docker info
Client: Docker Engine - Community
Version: 27.1.1
Context: default
Debug Mode: false
Plugins:
buildx: Docker Buildx (Docker Inc.)
Version: v0.16.1
Path: /usr/libexec/docker/cli-plugins/docker-buildx
compose: Docker Compose (Docker Inc.)
Version: v2.29.1
Path: /usr/libexec/docker/cli-plugins/docker-compose
Server:
Containers: 16
Running: 14
Paused: 0
Stopped: 2
Images: 33
Server Version: 27.1.1
Storage Driver: overlay2
Backing Filesystem: zfs
Supports d_type: true
Using metacopy: false
Native Overlay Diff: true
userxattr: false
Logging Driver: json-file
Cgroup Driver: cgroupfs
Cgroup Version: 2
Plugins:
Volume: local
Network: bridge host ipvlan macvlan null overlay
Log: awslogs fluentd gcplogs gelf journald json-file local splunk syslog
Swarm: inactive
Runtimes: io.containerd.runc.v2 runc
Default Runtime: runc
Init Binary: docker-init
containerd version: 2bf793ef6dc9a18e00cb12efb64355c2c9d5eb41
runc version: v1.1.13-0-g58aa920
init version: de40ad0
Security Options:
apparmor
seccomp
Profile: builtin
cgroupns
Kernel Version: 6.6.44-production+truenas
Operating System: Debian GNU/Linux 12 (bookworm)
OSType: linux
Architecture: x86_64
CPUs: 8
Total Memory: 15.59GiB
Name: fractal
ID: f85679be-c68a-4844-96c1-86e82be68d30
Docker Root Dir: /mnt/.ix-apps/docker
Debug Mode: false
Experimental: false
Insecure Registries:
127.0.0.0/8
Live Restore Enabled: false
Default Address Pools:
Base: 172.16.0.0/12, Size: 24
You can try my tutorial here - Nextcloud AIO v10.1.1 - Apache Will Not Start - #19 by vawaver
There is the part:
When Containers Don’t Start Properly:
If a container fails to start or is marked as “unhealthy” (e.g., the “apache” container), I’ve found that the installation image for that specific container might not have been downloaded correctly. In such cases, I follow these steps:
- Stop all containers as usual.
- Delete all stopped containers in Portainer, including the problematic one.
- Additionally, delete the installation image (in Portainer) for the Docker container that failed to start or was marked as unhealthy.
- Let the system redownload the image and recreate the container.This ensures that any potentially corrupted or incomplete image is replaced, and it has resolved issues for me multiple times.
Thanks for your idea. I just tried that. I stopped all containers except the mastercontainer, I deleted the containers and also all their images. Restarting took a while. In the end I still have the same situation: “Notify Push” stays in “Starting”.
Anything specific which I should try? Is it a problem? I don’t notice any problem in functionality of the software.
Hi, I just released AIO v11.4.0 stable. Can you please check if the problem still happens with that one?
I just upgraded my AIO installation to v11.4.0, but it shows the same behaviour. During testing in the last days, I also noticed situations where it was not “notify push” which stayed yellow, but “Imaginary” once as well (instead of of “notify push”). I also had once the situation, that it was “Apache”, which was staying yellow. This was especially bad, because then I couldn’t use the “stop containers” button in the control panel of AIO, as it was not displayed. Now after upgrading to v11.4.0, it is “notify push” again, which stays yellow.
This fixed the problem. Thank You!