AIO Notify Push container does not start (Permission denied)

Hello,

I moved my working AIO instance by backup and restore to a proxmox VM.
This is working great, besides the “Notify Push” container won’t start.

the log is full of:

/start.sh: line 36: /nextcloud/custom_apps/notify_push/bin/x86_64/notify_push: Permission denied

AIO 7.2.1
Intel N100
VM 8GB RAM 4 cores
no hickups so far (and waaay faster than api)

Where could i look?

How did you do that in detail?

Hello szaimen,

i have the same issue, restore Nextcloud-AIO 27.1.2 from Raspberry Pi via Borg-Backup to amd64 (Debian 12) => Proxmox-Container => new installation.

Error-Message :
start.sh: line 51: /nextcloud/custom_apps/notify_push/bin/x86_64/notify_push: Permission denied

Any idea … ?

Thanx for a short reply,
Marcus

This borg backup, did you use thw in AIO included solution or a custom one?

Both times, backup and restore : AIO included solution

Hm… Which Os is running docker?

Proxmox : Virtual Environment 8.0.4
Node-OS : Debian 12 (Bookworm)
Node-Kernel : Linux 6.2.16-15-pve #1 SMP PREEMPT_DYNAMIC PMX 6.2.16-15 (2023-09-28T13:53Z
Container-OS / Docker-OS: Debian 12

Raspberry-OS fully updated
Debian Host and Container fully updated
Nextcloud AIO v7.4.1 ( Nextcloud 27.1.2.1) both sides (new installation before restore)
Last borg-backup a few minutes before restore without any error

Hm… Can you try to disable and remove the Client Push app in the appstore and restart the containers and check if that makes it work?

3 Likes

Solved :grinning: , you are the best !

  • Deactivated Client Push in App-Section
  • Deinstalled Client Push in App-Section
  • Stopped containers
  • Started containers => All containers started
  • Installed Client Push in App-Section
  • Stopped containers
  • Started containers => All containers started

grafik

You are the best, is there any way to spend you a beer or a coffee ??
PM me, gerne auch auf deutsch

Herzlichen Dank für deine Unterstützung, liebe Grüße,
Marcus

P.S.: Die betreffenden Zeilen aus der start.sh, Ursache Zeile 51 (Ohne Stern am Anfang und Ende)
49 : # Run it
50 : /nextcloud/custom_apps/notify_push/bin/“$CPU_ARCH”/notify_push
*51 : --database-prefix=“oc_” *
52 : --nextcloud-url “https://$NC_DOMAIN”
53 : --port 7867

3 Likes

Yeah gladly via paypal. You should see the mail adress here (if you are logged in): szaimen (Simon L.) · GitHub

1 Like

Just yesterday I faced a similar issue when upgrading to AIO v7.5.1. Disabling and uninstalling Client Push plus restarting AIO didn’t help the situation. I had to ssh into the host, and ran chmod command to make the file executable.
chmod +x /var/lib/docker/volumes/nextcloud_aio_nextcloud/_data/custom_apps/notify_push/bin/x86_64/notify_push
After that, the Notify Push container automatically restarted nicely.

Perfect thanks, just ran a fresh install with AIO and removing the app didn’t help.

I had to run chmod +x /var/lib/docker/volumes/nextcloud_aio_nextcloud/_data/custom_apps/notify_push/bin/x86_64/notify_push not sure if you missed the “notify_push” at the end.

2 Likes

See this: App Broken after 0.6.4 upgrade · Issue #355 · nextcloud/notify_push · GitHub

This was my case also and your solution helped me. Thanks

Hello :slight_smile:
I am a newbie to the use and implementation of Nextcloud-AIO. Very very nice ! Daily backups and automatic updates (since 5d) are running smooth,

until the update of notify_push v0.6.3 to v0.6.4.

The topic “AIO Notify Push container does not start (Permission denied)” is marked as solved,

nevertheless the issue is not solved by the Nextcloud-AIO solution itself, is it ? Will it be automatically solved with the next daily update(s)?

I’m asking to find out if the automatic update process is a good choice.

According to the update policy

software components are under “test rounds” before pushed to AIO.

A computer scientist can solve it, but will it be solved without - by the Nextcloud-AIO itself ?

Best Greetings, Ive


Using: All-in-One VM image
https://download.nextcloud.com/aio-vm/

Nextcloud AIO v7.5.1
Nextcloud Hub 6 (27.1.3)
Using the integrated
Daily backup and automatic updates

Update
notify_push v0.6.3 to v0.6.4
03:00 UTC at Nov 9 23

database_dump.sql
before:
notify_push installed_version 0.6.3
notify_push types filesystem
after:
notify_push installed_version 0.6.4
notify_push types filesystem

Containers:

Notify Push (Starting)

Waiting for Nextcloud to start…
/start.sh: line 51: /nextcloud/custom_apps/notify_push/bin/x86_64/notify_push: Permission denied

+1 for this solution, thanks so much!

@HansoSchimpanso @szaimen I had exactly the same issue. I followed the process you showed. It worked! However, I didn’t need to Install the Client Push App. It was installed automatically once the containers had restarted.

Many thanks to you both

This is now fixed with 7.7.0 Beta. Testing and feedback is welcome! See GitHub - nextcloud/all-in-one: Nextcloud AIO stands for Nextcloud All-in-One and provides easy deployment and maintenance with most features included in this one Nextcloud instance.

Thanks. I wonder where the notify_push at the end went. Strange.

Just did an upgrade to v7.6.2. The same issue showed up again. The chmod +x command still works.