AIO docker installation script not working

Hello, I tried executing the docker installation script for Nextcloud AIO provided here.

I only added two environment variables as these are described here and here.

So my script is now this:

# For Linux and without a web server or reverse proxy (like Apache, Nginx, Cloudflare Tunnel and else) already in place:
sudo docker run \
--init \
--sig-proxy=false \
--name nextcloud-aio-mastercontainer \
--restart always \
--publish 80:80 \
--publish 8080:8080 \
--publish 8443:8443 \
--volume nextcloud_aio_mastercontainer:/mnt/docker-aio-config \
--volume /var/run/docker.sock:/var/run/docker.sock:ro \
--env NEXTCLOUD_DATADIR="/srv/ncdata"
--env NEXTCLOUD_MOUNT="/mnt"

Error message:

“docker run” requires at least 1 argument.
See ‘docker run --help’.
Usage: docker run [OPTIONS] IMAGE [COMMAND] [ARG…]
Create and run a new container from an image
–env: command not found
-bash: nextcloud/all-in-one:latest: No such file or directory

Anybody has an idea what is wrong here?

Note: I run Ubuntu Server 24.04

The escape character (backslash) is missing at the end of the two lines you have added.