AIO-Database not starting after update

Nextcloud version: latest (updated today (cannot enter so cannot check))
AIO version: 9.0.1
Operating system and version: Windows 10 Pro 22H2 Build 19045.4529
Docker version: 4.31.1
Apache or nginx version: latest
PHP version: latest

The issue you are facing:

After updating, the nextcloud-aio-database container in docker is in an endless restart-loop

Is this the first time you’ve seen this error?: Yes

Steps to replicate it:

  1. Update nextcloud containers via AIO interface

Log files:
AIO update log: https://pastebin.com/G8r4YwR0
Database container log (from AIO interface): https://pastebin.com/D1fEkq9h

I am sorry but I have no idea how to get the other requested logs

I don’t know if the info helps but since a while I must restart the machine after an update otherwise the containers won’t communicate with each other.

Stopping the containers in the AIO interface says they are up to date.

What I tried:

  • restart the physical machine Docker is running on
  • update Docker (and restart the machine)
  • force pulling the images in Docker in case the update went wrong
  • manually stop and start the container

All to no avail so I request aid and offer thanks in advance

Hi, can you post the complete database logs here? If have the feeling something important is missing there

Right now it contains just an endless repetition of:

The database import failed. Please restore a backup and try again.
For further clues on what went wrong, look at the logs above.

The rest of the log seems to be overwritten, unless there is a way to get a longer log which however I wouldn’t know.

I did make a backup before updating but I am hesitant to roll back given it may not resolve the error, unless recommended to do so.

There should be a database-import.log file in the nextcloud_aio_database_dump volume. Can you post its content here?

Yes, that would be here: https://pastebin.com/XxkXXvwZ

I see. Can you try the following?

This worked.
Executed the command, restored a backup with borg backup and clicked start and update in the AIO interface.
Thank you very much!

1 Like

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.