AIO Backup: configuration.json not present

Hello community!

i installed nextcloud-aio via docker-compose:

# ignored options for 'all-in-one'
# --sig-proxy=false
version: "3.3"
    init: true
    container_name: nextcloud-aio-mastercontainer
    restart: always
      - 8080:8080
      - APACHE_PORT=11000
      - NEXTCLOUD_DATADIR=/mnt/fastplate/nextcloud-data
      - nextcloud_aio_mastercontainer:/mnt/docker-aio-config
      - /var/run/docker.sock:/var/run/docker.sock:ro
      - /mnt/fastplate/nextcloud/data:/mnt/fastplate/nextcloud-data
      - /mnt/fastplate/nextcloud/backup
    image: nextcloud/all-in-one:latest
  nextcloud_aio_mastercontainer: {}
networks: {}

And now i get the error that borg backups can’t be done because the configuration.json is missing. I already found this entry and i have the same problem that my volume got a different name. As you can see i didn’t change the volume name in my docker-compose, but apparently dockge (the compose webui i use) changed it to:



"Mounts": [
                "Type": "volume",
                "Name": "nextcloud-aio_nextcloud_aio_mastercontainer",
                "Source": "/var/lib/docker/volumes/nextcloud-aio_nextcloud_aio_mastercontainer/_data",
                "Destination": "/mnt/docker-aio-config",
                "Driver": "local",
                "Mode": "z",
                "RW": true,
                "Propagation": ""

Now i was a little bit stupid to be honest and i am willing to admit that. When i installed nextcloud AIO and tried the backup, it failed with that exact cause. I didn’t care too much and proceeded with my setting up of nextcloud and i am using it just fine… but it nags me that i don’t have working backups.

Now, is it somehow possible to correct the volume name so the borg backups work and NOT break the container because now the name is different? :sweat:

Hopefully someone can help me out here… i am fully aware that this is 100% on me for using nextcloud despite me knowing that backups didn’t work properly.

Hi, maybe this helps?

Of course you need to adjust the commands accordingly to your setup

Thanks! I’ll try that right away!

This didn’t work as compose simply recreated the wrongly named volume again… i found something about declaring the volume to be external so it doesn’t create the volume but i don’t get this to work :thinking:

Please compare with all-in-one/compose.yaml at 07a8367181135e00de58ba88a2b0a679dbd36ab5 · nextcloud/all-in-one · GitHub

1 Like

I’m a big dumdum, yup forgot the “name” part

Thanks and have a nice day!

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.