Again CalDav Problem

missing_information

#1

Hello
i had a couple of weeks ago a problem with caldav but at the end it did work.

now my samsung has been resetet, (some kids playing around and after 4 wrong code - factory Reset)
i installed calDav again an try to sync but got a error and no connection. but why it is not working this time?

2018-10-26 19:33:31 7661 [HttpClient] <-- END HTTP (624-byte body)
2018-10-26 19:33:31 7661 [HttpClient] --> PROPFIND http://nextcloud.kozo.ch/.well-known/carddav
2018-10-26 19:33:31 7661 [HttpClient] Content-Type: application/xml; charset=utf-8
2018-10-26 19:33:31 7661 [HttpClient] Content-Length: 198
2018-10-26 19:33:31 7661 [HttpClient] Depth: 0
2018-10-26 19:33:31 7661 [HttpClient]
2018-10-26 19:33:31 7661 [HttpClient] <?xml version='1.0' encoding='UTF-8' ?>
2018-10-26 19:33:31 7661 [HttpClient] --> END PROPFIND (198-byte body)
2018-10-26 19:33:31 7661 [HttpClient] <-- 405 Method Not Allowed http://nextcloud.kozo.ch/.well-known/carddav (7ms)
2018-10-26 19:33:31 7661 [HttpClient] Date: Fri, 26 Oct 2018 17:33:32 GMT


#2

i found this documentation
https://docs.nextcloud.com/server/14/admin_manual/issues/general_troubleshooting.html#service-discovery
and changed the file like this

vi /var/www/html/nextcloud/.htaccess
81 #### DO NOT CHANGE ANYTHING ABOVE THIS LINE ####
82 Redirect 301 /.well-known/carddav /nextcloud/remote.php/dav
83 Redirect 301 /.well-known/caldav /nextcloud/remote.php/dav
84
85 ErrorDocument 403 //
86 ErrorDocument 404 //

and after rebootet the server too


#3

any feedback or place to look at, why it is not connecting?


#4

Done some update - also installed DAVx5 but still error on the connection.
Some other Phone also connected but still works, only problems to add new Phones.

— BEGIN DEBUG INFO — LOGS: 2019-01-09 19:20:17 1572 [ui.setup.DavResourceFinder] Finding initial carddav service configuration 2019-01-09 19:20:17 1572 [ui.setup.DavResourceFinder] Checking user-given URL: http://nextcloud.kozo.ch/remote.php/webdav/ 2019-01-09 19:20:17 1572 [HttpClient] --> PROPFIND http://nextcloud.kozo.ch/remote.php/webdav/ 2019-01-09 19:20:17 1572 [HttpClient] Content-Type: application/xml; charset=utf-8 2019-01-09 19:20:17 1572 [HttpClient] Content-Length: 290 2019-01-09 19:20:17 1572 [HttpClient] Depth: 0 2019-01-09 19:20:17 1572 [HttpClient] 2019-01-09 19:20:17 1572 [HttpClient] <propfind><prop><resourcetype></resourcetype>
<displayname></displayname>
<addressbook-description></addressbook-description>
<addressbook-home-set></addressbook-home-set>
<current-user-principal></current-user-principal>
</prop>
</propfind>
2019-01-09 19:20:17 1572 [HttpClient] --> END PROPFIND (290-byte body) 2019-01-09 19:20:18 1572 [HttpClient] <_-- _207="_207" multi-status=“multi-status” ="http:" nextcloud.kozo.ch=“nextcloud.kozo.ch” remote.php=“remote.php” webdav=“webdav” _644ms="_644ms" _2019-01-09="_2019-01-09" _2018="_19:_2018" _1572="_1572" httpclient=“httpclient” ="date:" wed=“wed” _09="_09" jan=“jan” _2019="_2019" _2019="_18:_2019" gmt=“gmt” ="server:" apache=“apache” _2.4.25="_2.4.25" debian=“debian” ="expires:" thu=“thu” _19="_19" nov=“nov” _1981="_1981" _5200="_08:_5200" ="cache-control:" no-store=“no-store” no-cache=“no-cache” must-revalidate=“must-revalidate” ="pragma:" ="content-security-policy:" default-src=“default-src” none=“none” ="x-frame-options:" sameorigin=“sameorigin” ="x-xss-protection:" _1="_1" mode=“block” ="x-content-type-options:" nosniff=“nosniff” ="x-robots-tag:" ="x-download-options:" noopen=“noopen” ="x-permitted-cross-domain-policies:" ="set-cookie:" ockufx15novv=“5020hs4d3hm1pcpj400hkjf1v0;” path="/;" httponly=“httponly” cookie_test=“test;” expires=“Wed,” _09-jan-2019="_09-jan-2019" _2019="_19:_2019" max-age=“3600” ="vary:" briefprefer=“briefprefer” ="dav:" _3="_3" extended-mkcol=“extended-mkcol” ="content-length:" _624=“624" ="keep-alive:" timeout=“5,” max=“99” ="connection:" keep-alive=“keep-alive” ="content-type:" application=“application” xml=“xml” charset=“utf-8” version=“1.0” =""><multistatus><response><href>/remote.php/webdav/</href>
<propstat><prop><resourcetype><collection></collection>
</resourcetype>
</prop>
<status>HTTP/1.1 200 OK</status>
</propstat>
<propstat><prop><displayname></displayname>
<addressbook-description></addressbook-description>
<addressbook-home-set></addressbook-home-set>
<current-user-principal></current-user-principal>
</prop>
<status>HTTP/1.1 404 Not Found</status>
</propstat>
</response>
</multistatus>
2019-01-09 19:20:18 1572 [HttpClient] <
– end=“end” http=“http” _624-byte=”_624-byte" body=“body” _2019-01-09="_2019-01-09" _2018="_19:_2018" _1572=“1572" httpclient=“httpclient” –="–">PROPFIND http://nextcloud.kozo.ch/.well-known/carddav 2019-01-09 19:20:18 1572 [HttpClient] Content-Type: application/xml; charset=utf-8 2019-01-09 19:20:18 1572 [HttpClient] Content-Length: 198 2019-01-09 19:20:18 1572 [HttpClient] Depth: 0 2019-01-09 19:20:18 1572 [HttpClient] 2019-01-09 19:20:18 1572 [HttpClient] <propfind><prop><current-user-principal></current-user-principal>
</prop>
</propfind>
2019-01-09 19:20:18 1572 [HttpClient] --> END PROPFIND (198-byte body) 2019-01-09 19:20:18 1572 [HttpClient] <
– _405=”_405" method=“method” not=“not” allowed=“allowed” ="http:" nextcloud.kozo.ch=“nextcloud.kozo.ch” .well-known=".well-known" carddav=“carddav” _13ms="_13ms" _2019-01-09="_2019-01-09" _2018="_19:_2018" _1572="_1572" httpclient=“httpclient” ="date:" wed=“wed” _09="_09" jan=“jan” _2019="_2019" _2019="_18:_2019" gmt=“gmt” ="server:" apache=“apache” _2.4.25="_2.4.25" debian=“debian” ="allow:" getheadpostoptionsheadhead=“getheadpostoptionsheadhead” ="content-length:" _328="_328" ="keep-alive:" timeout=“5,” max=“98” ="connection:" keep-alive=“keep-alive” ="content-type:" text=“text” html=“html” cha