After upgrade to Nextcloud 12, running into code integrity check problem

Hello, I am getting a popup notification about problems with the code integrity check.
Below is the output. Cannot find a cure for this and would appreciate some help.

Some files have not passed the integrity check. Further information on how to resolve this issue can be found in our documentation. (List of invalid files… / Rescan…)

Technical information

The following list covers which files have failed the integrity check. Please read
the previous linked documentation to learn more about the errors and how to fix
them.

Results

  • core
    • INVALID_HASH
      • .htaccess

Raw output

Array
(
[core] => Array
(
[INVALID_HASH] => Array
(
[.htaccess] => Array
(
[expected] => da8e0075f23227b107fc705aa1b20378107d3a1c195d96ed13e5f4f25c38d6c660aab75be183ae5799a4ff7eae0ea739a14c944430ee8bb9e9a824235aa136eb
[current] => e0da651dd6f73f11ff3b792867ccd3fcbfa61dfe18f90b9705638797d982d5597b830a180ad13c73d0fc8a2f246d34361d1c57d45c1e2dd0ab8fe3cbaaaa5281
)

            )

    )

)

Deleting the file {installation-folder}/.htaccess and replacing it by the one from the ZIP or TAR.BZ2 file might solve the issue.

1 Like

Hello @Uli_He,

Thank you it worked …much appreciated.

It does not work for. I have still the same problem!

Results

=======

  • core
    • INVALID_HASH
      • .htaccess

Raw output

Array
(
[core] => Array
(
[INVALID_HASH] => Array
(
[.htaccess] => Array
(
[expected] => da8e0075f23227b107fc705aa1b20378107d3a1c195d96ed13e5f4f25c38d6c660aab75be183ae5799a4ff7eae0ea739a14c944430ee8bb9e9a824235aa136eb
[current] => 73effe32dfbc8d58cfef17bbc7b7abe976f38384d663df2f05918fc997def94ca09f43fba52b58af4096513082169df87ea3550ae80594f4743ed076f2a3326e
)

            )

    )

)

Hello @OliverBerlin did you do rescan ?

Thank you sooo much! It wirks now! :slight_smile:

I have the same problem. I’ve done the rescan a few times now. I’m using the “NextCloud VM”, so to update I just run the included script. I didn’t have the error before, but I do since the upgrade to 12. This error is driving me nuts, is it possible to disable it?

EDIT -> I also tried to simply grab the latest .htaccess file from github and replaced my existing one, but that didn’t work either. To be honest, this was just a test to see if I could resolve the error. I have upped the upload limits to 5 GB so the default .htaccess doesn’t work for me.

@ssn760
It should be straight forward. the file htaccess should not be touched or altered also it should be with permissions 644
please make sure your apps folder does not contain foreign applications.

The best practice to avoid errors as such.
prior to executing the update script,

  1. check your apps folder and remove all foreign apps, apps that you manually installed from the shell prompt. if installed from the app store using the web interface those are no considered foreign.
  2. go to the apps from the browser and update all apps to their latest versions. You will be able to identify that by a red notification displaying a newer version exist.
  3. Check the desired Nextcloud version incompatible apps list. make sure you disable and uninstall those from the nextcloud prior to the upgrade.

If you do all above you will not see a single error nor have to change any file.

Thanks for the quick reply Giorgio. I updated my apps after the upgrade instead of before, could that be the issue? If so, how do I resolve it now? I do not have any foreign apps, and my .htaccess file is indeed 644.

@ssn760 from my little experience you made a mistake.
I am not sure if you have the upgrade log, in that log you will see which apps were not compatible.
What you should do is to disable and to remove them (uninstall) and remove from the apps directory.
Then you need to run rescan and see if your code integrity is resolved.
Other than that I personally had to restore the version 11.0.x upgrade apps. remove the ones that were not compatible then update.
Been running the 12 for one week now with no issues at all except on spreed.me which is now resolved.
good luck