After updating to 17.0.1 Web Login not working

Hi, I am not able to login to nextcloud.

There is no apache2 error but I find this in the nextcloud log:

":"admin","app":"cssresourceloader","method":"GET","url":"\/index.php\/apps\/files\/","message":"Could not find resource css\/server.css to load"

I am running Nextcloud 17.0.1 on Ubuntu 18 with apache 2

Any help is highly appreciated!

1 Like

Have you eventually played around with the theming of Nextcloud? The only location where I find a file called “server.css” on the server is the directory “./themes/example/core/css”.

Thanks for answering!

I used an app “unsplash” (changing the background picture) in nextcloud 16, during the process to update to 17.0.1 the updater said its not compatible and it will be disabled. Which wasnt the case but nextcloud worked anyway. Out of a sudden nextcloud stopped working (the web login, the rest works) and I dont know why. I already disabled “unsplash” via console but this also didnt solve the issue.

You could try adding the missing file as a temporary workaround.

Thanks for the suggestion. Unfortunately I am not that experienced, where should I put the file? And to add, I also find this file as “j-ed” mentioned in " ./themes/example/core/css"

I tried maintenance repair but that also did not help.

Digging into the log file I discovered, that (propably) every css ist not found and these error messages (below). And yes, all the files are present and I did not change them.

Can anyone help?

Failed to compile and\/or save \/var\/www\/html\/nextcloud\/core\/css\/server.scss

Failed to compile and\/or save \/var\/www\/html\/nextcloud\/core\/css\/css-variables.scss

I somehow solved the issue.

I dont know what might have helped but I tried these things:

Basically all possible maintenance commands

And I checked again apps and noticed that a “admin_audit” app was disabled. I neved disabled this so I enabled it again.

After all these changes Nextcloud again works as it supposed to work.

1 Like