After trying to save a new password on website, Password manager ends with 504 - Gateway-timeout (nginx)

I use my password manager since a few days and it worked perfect so far! Today I visited a website, where I entered my login credentials and wanted to store them with the Firefox AddOn into Nextcloud 25.0.0
I hit the little disk to store the password but nothing happened. So I clicked it a few times more but nothing happened.
To see if the password was stored in my password manager, I entered my Nextcloud via Firefox and clicked on the “Passwords” Button in the top bar. The site is loading and ends with a 504 Gateway-timeout (nginx) error. Other Apps like dashboard, Files, Photos, Calendar and Contacts work perfect. Even in the settings menu, most menus work, except: Apps button; In the administration menu: Overview, Passwords and System.

I have the bad feeling, that something is wrong with my password manager. What could I try to do?

Firefox 102.5.0esr with Passwords for Nextcloud extension (v. 2.2.6)
Nexcloud 25.0.0 running on TrueNas Core (TrueNAS-12.0-U8.1)

You can check the Nextcloud logs to see if there are any errors related to the app.
You can also try to use the database repair job if there would be anything wrong with the database.

Thanks for the info. I will try that. But one more question. If I type in the command in shell I get “permission denied”. But how could I sudo those occ commands?

edit: found it!
su -m www -c 'php ./occ maintenance:repair'

I repaired the database, installed a backup from a day before but it seems to be still the same problem. What else can I try?
Thanks for your help.

Did you check the logs?

yes, I found this:
[PHP] Fehler: Error: dns_get_record(): A temporary server error occurred. at /usr/local/www/nextcloud/lib/private/Http/Client/DnsPinMiddleware.php#83 at <>

  1. <>
    OC\Log\ErrorHandler::onError(2, “dns_get_record( … .”, “/usr/local/www/ … p”, 83, [“”,1, … "])
  2. /usr/local/www/nextcloud/lib/private/Http/Client/DnsPinMiddleware.php line 83
    dns_get_record(“”, 16)
  3. /usr/local/www/nextcloud/lib/private/Http/Client/DnsPinMiddleware.php line 128
    OC\Http\Client\DnsPinMiddleware->dnsResolve(“”, 1)
  4. /usr/local/www/nextcloud/3rdparty/guzzlehttp/guzzle/src/PrepareBodyMiddleware.php line 35
    OC\Http\Client\DnsPinMiddleware->OC\Http\Client{closure}(“*** sensitive parameters replaced ***”)
  5. /usr/local/www/nextcloud/3rdparty/guzzlehttp/guzzle/src/Middleware.php line 31
    GuzzleHttp\PrepareBodyMiddleware->__invoke(“*** sensitive parameters replaced ", " sensitive parameters replaced ***”)
  6. /usr/local/www/nextcloud/3rdparty/guzzlehttp/guzzle/src/RedirectMiddleware.php line 71
    GuzzleHttp\Middleware::GuzzleHttp{closure}(“*** sensitive parameters replaced ***”)
  7. /usr/local/www/nextcloud/3rdparty/guzzlehttp/guzzle/src/Middleware.php line 63
    GuzzleHttp\RedirectMiddleware->__invoke(“*** sensitive parameters replaced ", " sensitive parameters replaced ***”)
  8. /usr/local/www/nextcloud/3rdparty/guzzlehttp/guzzle/src/HandlerStack.php line 75
    GuzzleHttp\Middleware::GuzzleHttp{closure}(“*** sensitive parameters replaced ***”)
  9. /usr/local/www/nextcloud/3rdparty/guzzlehttp/guzzle/src/Client.php line 331
    GuzzleHttp\HandlerStack->__invoke(“*** sensitive parameters replaced ", " sensitive parameters replaced ***”)
  10. /usr/local/www/nextcloud/3rdparty/guzzlehttp/guzzle/src/Client.php line 168
    GuzzleHttp\Client->transfer(“*** sensitive parameters replaced ", " sensitive parameters replaced ***”)
  11. /usr/local/www/nextcloud/3rdparty/guzzlehttp/guzzle/src/Client.php line 187
    GuzzleHttp\Client->requestAsync(“get”, GuzzleHttp\Psr7\Uri {}, ["/usr/local/www … "])
  12. /usr/local/www/nextcloud/lib/private/Http/Client/Client.php line 218
    GuzzleHttp\Client->request(“get”, “https://api.met … 9”, ["/usr/local/www … "])
  13. /usr/local/www/nextcloud/apps-pkg/weather_status/lib/Service/WeatherStatusService.php line 415
    OC\Http\Client\Client->get(“https://api.met … 9”, [["NextcloudWeat … ]])
  14. /usr/local/www/nextcloud/apps-pkg/weather_status/lib/Service/WeatherStatusService.php line 380
    OCA\WeatherStatus\Service\WeatherStatusService->requestJSON(“https://api.met … t”, [“54.17”,“12.34”,29])
  15. /usr/local/www/nextcloud/apps-pkg/weather_status/lib/Service/WeatherStatusService.php line 358
    OCA\WeatherStatus\Service\WeatherStatusService->forecastRequest(54.1707198, 12.3416938, 29)
  16. /usr/local/www/nextcloud/apps-pkg/weather_status/lib/Controller/WeatherStatusController.php line 118
  17. /usr/local/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php line 225
  18. /usr/local/www/nextcloud/lib/private/AppFramework/Http/Dispatcher.php line 133
    OC\AppFramework\Http\Dispatcher->executeController(OCA\WeatherStatu … {}, “getForecast”)
  19. /usr/local/www/nextcloud/lib/private/AppFramework/App.php line 172
    OC\AppFramework\Http\Dispatcher->dispatch(OCA\WeatherStatu … {}, “getForecast”)
  20. /usr/local/www/nextcloud/lib/private/Route/Router.php line 298
    OC\AppFramework\App::main(“OCA\WeatherSta … r”, “getForecast”, OC\AppFramework\ … {}, ["ocs.weather_st … "])
  21. /usr/local/www/nextcloud/ocs/v1.php line 63
    OC\Route\Router->match(“/ocsapp/apps/we … t”)
  22. /usr/local/www/nextcloud/ocs/v2.php line 23

GET /ocs/v2.php/apps/weather_status/api/v1/forecast
from by Konrad at 2022-11-21T17:37:50+00:00

This might be easier to read.

There seems to be quite some stuff to be going on with url resolving on your system.

I would recommend the following:

  • Install the Passwords Handbook app (if possible) so the app does not try to use the online handbook (which seems to be not reachable)
  • Use the PHP GDlib optin for image rendering in the Passwords App settings
  • Use one of the local database options for the password security check in the Password app settings (since your server isn’t online, here is how to create that database:
  • Use none for favicon service and preview service in the Password app settings

Thanks for your help! I changed one thing to try it out as I had the IP adress of my Jail on the same IP as the Truenas (VNET on; Last night I played with different IP settings and couldn’t get it back to work with VNET. So I disabled VNET in the jail and assigned a static IP adress ( which worked fine until today.
Now I tried to set the IP to DHCP ( and when I now use Nextcloud, everthing works perfect again. What could be the problem with my currently used IP?